Default.png wont change

Discussion in 'iOS Programming' started by Danneman101, Feb 19, 2009.

  1. Danneman101
    Expand Collapse
    macrumors 6502

    Joined:
    Aug 14, 2008
    #1
    Ive replaced the Default.png with another one in my project. However, the image wont change when the application is launched (in simulator) and I still get the old image.

    I thought that perhaps the image is loaded from somewhere else, so I renamed all copies of the old Default.png to _Default.png on my entire computer. Still, the old image keeps appearing!

    Any suggestions?
     
  2. dejo
    Expand Collapse
    Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
  3. Danneman101
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Aug 14, 2008
    #3
    Can I safely remove everything inside the "build" folder?
     
  4. jnic
    Expand Collapse
    macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #4
    No need to do it manually.

    Build > Clean All Targets > Clean
     
  5. boyplunder
    Expand Collapse
    macrumors regular

    boyplunder

    Joined:
    Sep 8, 2008
    Location:
    UK
    #5
    Reset the iPhone simulator

    I find that resetting the iPhone simulator works most of the time in this case. Select 'Reset content and settings' from the iPhone Simulator menu. Quit the sim and click build and go again.

    Boypunder
     
  6. Danneman101
    Expand Collapse
    thread starter macrumors 6502

    Joined:
    Aug 14, 2008
    #6
    That was sufficient - thanks :)

    boyplunder: Tried that, but didnt reset the image.
     
  7. dejo
    Expand Collapse
    Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #7
    I only see "Build > Clean" and "Build > Clean All Targets". Did you mean an or in your case?
     
  8. jnic
    Expand Collapse
    macrumors 6502a

    Joined:
    Oct 24, 2008
    Location:
    Cambridge
    #8
    I did, well spotted :)
     
  9. dejo
    Expand Collapse
    Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #9
    Thanks. Just wanted to make sure we were being clear to the newbies. :D
     

Share This Page