Delay when receiving text messages?

Discussion in 'iPhone Tips, Help and Troubleshooting' started by illjazz, Aug 22, 2008.

  1. macrumors regular

    Apr 18, 2008
    This is new. Just started happening two days ago or yesterday. I've never had this happen before.. I tested it tonight with a friend and confirmed it to be a serious problem: all incoming texts are delayed by what appears to be exactly 14 minutes. What's interesting is that the only other thread I found on this on the web is this one here:

    And guess what? 14 minutes! Pretty weird, eh? Am I alone with this? I have an iPhone 3G and it's been working perfectly fine since a day after launch day. I'm running 2.0.2 and all other possibly related software is updated and current.

    This must be AT&T related, so I suppose I'll give them a call later today. It's a very vexing problem because you have the sender waiting on your response while you don't even know you were sent a text message until 14 minutes after it's sent.. I'm too tired to be fuming mad about this, but then I never really get "fuming mad". Just thought I'd share and see whether I'm alone.
  2. Joined:
    Jul 1, 2007
    Let me know what you find out on this. I've been getting delays like this since I got my iPhone 3G. Usually around 10 minutes, but sometimes longer (actually close to 15 now that you mention it) except for around 1 or 2 AM which is fine. I'm guessing due to the network being hit less. But none the less it drives me and the person I'm texting insane.
  3. macrumors 68000


    Jul 15, 2006
    Im going to go out on a limb and say that you are on the Ter'rist watch list and that all texts are going to the CIA and FBI, and some other illegal organization where they can read everything. :D

    Or maybe not... ;)
  4. thread starter macrumors regular

    Apr 18, 2008
    Well I did a full restore of my phone Friday morning, and that appears to have fixed the problem. What I think is more realistic is that AT&T fixed their issues overnight and that that coincided with my restoring the phone. I'll never know, I guess.
  5. macrumors 6502a


    Jan 4, 2004
    in the toe-jam of greatness (Fort Worth)
    I've had delays from several minutes to 5-12 hours since I got my 3g.
  6. thread starter macrumors regular

    Apr 18, 2008
    I still don't know whether ATT got their act together and fixed it or if it was my phone restore that did it.. either way, I don't have any delays anymore.

Share This Page