Deleting Autofill Email Address

Discussion in 'iOS 5 and earlier' started by captsanner295, Nov 11, 2011.

  1. macrumors member

    Joined:
    Sep 4, 2010
    #1
    Not sure if this has ever been answered. Ive searched countless threads with no real solution. I have an email address that is not in any contact, and was initally typed incorrectly and sent email. The email was corrected in contact info but the incorrect email still comes up with autofill with the correct email address. Is there anyway to keep this incorrect email from coming up with auto fill.

    Thanks
    TJ
     
  2. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #2
    Which email service are you using (e.g. Gmail)? I don't immediately have a solution for you but will gladly test to see if I can figure it out.
     
  3. thread starter macrumors member

    Joined:
    Sep 4, 2010
    #3
    Thanks. Just in Mail on the iphone. But its IMAP to gmail. Mail is doing the incorrect autofill.
     
  4. macrumors 65816

    Joined:
    Nov 10, 2010
    Location:
    US
    #4
    Back in March I asked the same question and no one knew the answer. It appears that every address you use goes into the list. I use the Apple Mail app and a Yahoo Mail account. I'm still looking for the answer.
     
  5. macrumors 6502a

    atlanticza

    Joined:
    Jul 18, 2008
    Location:
    Cape Town
    #5
    I had the same problem but fixed it. Type the incorrect email address into the TO: field. Mouse over email address and click on the small down arrow at the end of the email address. Select Remove Address. If you find it still appears, select the option Edit Address, delete the entire address and discard the email. Worked for me.
     

    Attached Files:

  6. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #6
    Okay, I tested this by sending an email from my iPhone to a bogus email address and unfortunately have been unable to find a way to delete that email address from the auto-fill menu. I tried numerous things and none of them worked.

    I subsequently searched Google and found others that had the same problem and the only solution that seems to work is to restore the iPhone as new. Not what I was hoping to hear. Now I have a bogus email address in my auto-fill menu. :D

    My suggestion if you have this same problem is to submit the issue to Apple using their Feedback form in hopes that they eventually fix this.
     
  7. macrumors regular

    sulliweb

    Joined:
    Mar 13, 2011
    #7
    Not sure if this is accurate... as I've only noticed this with one address, that was a contact...

    Still, I have e-mailed from my phone to a couple of e-mails that aren't in the list anymore... The only thing I know that's happened was that I deleted the offending account that I sent the message from.

    Have you tried that? Delete the account, close settings app and mail app, reboot the phone, then add the account back?

    Again, no guarantees or anything, just a random thought I had that seemed worth mentioning.

    Later.
     
  8. macrumors 68000

    r2shyyou

    Joined:
    Oct 3, 2010
    Location:
    Paris, France
    #8
    I tried that in my test (sorry if I didn't specify that in my above post). I created a Gmail account, added it on my iPhone, sent a test email to a bogus email address, and then deleted the Gmail account in hopes that it would remove the bogus address. Unfortunately, it didn't.
     

Share This Page