Deleting Purchased Songs on iOS 7

Discussion in 'iOS 7' started by Pacmtrx7, Sep 18, 2013.

  1. macrumors newbie

    Joined:
    Sep 18, 2013
    #1
    I have synced my device numerous times on iTunes trying to remove purchased songs off my iPhone 5, but they just won't come off. I have tried checking manually manage songs and unchecking all the songs and after it syncs it still has the purchased songs on there. It even says 0 songs to sync, but they still remain.
    Didn't it use to have the capability to just swipe the song on the phone and delete it? Doesn't seem to have that option anymore now.
    Anyone else having this issue?
     
  2. macrumors 68040

    chrf097

    Joined:
    Dec 16, 2011
    Location:
    Earth
    #2
    Settings --> Music --> Show all Music

    See if that helps :)
     
  3. thread starter macrumors newbie

    Joined:
    Sep 18, 2013
    #3
    Thank you! That seems to have taken the majority of the songs off but still a few remain. I checked manually manage and everything is unchecked. Anything else I'm missing?
     
  4. macrumors member

    Mr.Chow

    Joined:
    Jan 27, 2013
    Location:
    Austria
    #4
    Log out of AppStore in settings and turn "show all music" on and off again. Check out if it worked and keep this turned off and log back into appstore..
    this worked for me.
     
  5. thread starter macrumors newbie

    Joined:
    Sep 18, 2013
    #5
    I logged out of the appstore on my Iphone and I didn't see the "show all music" tab anymore under appstore or music. I don't need to do anything on iTunes?
    Can you please specify.
     
  6. macrumors member

    Mr.Chow

    Joined:
    Jan 27, 2013
    Location:
    Austria
    #6
    -log out of appstore
    -close music app
    -open it again and check if those songs will still show up
    -if not close music app again & log back into appstore
    -check if "show all music" is turned off

    then you should be ready to go. no need for itunes.
     
  7. macrumors newbie

    Joined:
    Aug 30, 2012
    #7
    Is that the only way? There is no permantely deleting songs from the purchased section on the iphone??
     
  8. macrumors 6502

    Joined:
    Feb 27, 2011
    #8
    OK, this is supremely annoying... I've tried everything.

    My kid has a few songs he bought on iTunes a while ago. Hates those songs now and wants them off his phone.

    Have NOT found a way to delete. Tried all the "Show all songs" trick, and nothing. Tried deleting while connected to iTunes and sync'd. No go on any front. Can't get rid of them.

    If it shows the cloud you can't swipe to delete.

    If you download from the cloud, it lets you swipe to delete, but all it does then is show the cloud so you can download again.

    Repeat until insane.

    How could this be?
     
  9. macrumors 65816

    Joined:
    Apr 4, 2007
    Location:
    los angeles
    #9
    Same problem. I have a few songs that will not go away.
     
  10. macrumors 6502a

    Joined:
    Jun 14, 2013
    Location:
    Wales, UK
    #10
    You have to do it from iTunes. This should solve your dilemma:

    http://support.apple.com/kb/HT4919
     
  11. macrumors 68030

    Joined:
    Jul 21, 2011
    Location:
    Los Angeles, CA
    #11
    If there is a cloud next the track that means its not actually on your device its on iCloud. By turning off show all music you will see only what is on your device. You can delete songs from iCloud by going into iTunes on a desktop and deleting it...it will ask if you want to remove it from iCloud.
     
  12. macrumors 6502

    Joined:
    Feb 27, 2011
    #12
    awesome. I'll check it out. Never have seen that choice!
     
  13. tgi
    macrumors 65816

    tgi

    Joined:
    Aug 29, 2012
    #13
    I'll have to try that too.

    Let us know how it works out!
     
  14. macrumors member

    Joined:
    May 23, 2008
    #14
    This doesn't work. It hides it in iTunes on the computer, but not on the phone. Bah. This whole music delete thing is insane. It's all or nothing apparently, with icloud.
     
  15. macrumors member

    Joined:
    Nov 27, 2012
    #15

    This did the trick, the tracks instantly disappeared from all iOS-devices. Thank you,man!
     
  16. macrumors regular

    Joined:
    Jan 16, 2013
    #16
    Sorry for a thread hijack, but I have this problem in a upside down way. Back in iOS6, I bought one album from iTunes. Now that I have updated to iOS7 many many weeks ago I only just noticed that the album isn't on my phone anymore. When I go to iTunes, it shows that I have to pay again for it?!

    So any way I can get this album back to my phone?
     
  17. macrumors newbie

    Joined:
    Jan 14, 2014
    #17
    If you didnt have the songs on the iPad before you updated but you purchased it, there is a feature enabled by default that shows all music. to turn it off go to settings/music/show all music-off. Otherwise, to delete music, swipe from right to left over what you want to delete.
     
  18. macrumors 6502

    Joined:
    Jul 4, 2012
    #18
    I have a bunch of song that I have no idea where they came from - are Christmas songs and I never asked for them etc. They all show clouds next to them so I know they aren't on my device but having to turn off show all songs seems like stupid way - what if I have match running and need to download some songs.

    1) Why do I have songs I never asked for and
    2) Why can't I really get rid of them
     
  19. macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #19
    You have to do it in iTunes. I had this issue once and I found it under the music tab in iTunes. Not sure what I did after that, but it was a few things.
     
  20. Azy, Jan 16, 2014
    Last edited: Jan 16, 2014

    Azy
    macrumors regular

    Joined:
    Jun 13, 2012
    #20
    OP: you did not want to tick Manually manage my music, that will take away syncing abilities. What you do want to tick is 'Sync only checked songs and videos'. That way anything that is not ticked in your iTunes folder in your computer will be removed from your phone. Press apply and then Sync. Also follow the steps previous posters have made for you to not 'show all music' via settings on your phone so music on iCloud doesn't show also and you should be good!

    If you don't want I use syncing for your library then leave 'manually manage music and videos' checked but click on the "on this iPhone" tab in iTunes and remove whatever you want in that page and it will remove it from your phones library.

    Obviously connect your phone to iTunes prior to the above steps.

    Hope this helps
     

    Attached Files:

Share This Page