Desktop icons skipping a row

Discussion in 'Mac Basics and Help' started by elbirth, Jun 30, 2006.

  1. elbirth macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #1
    I try not to have very many icons on my desktop if I can help it... however I have Firefox set to download to the Desktop by default, and for my job I'm looking at a lot of PDFs, so I end up with a lot on my desktop before I delete them.

    Anyway, once the first row of icons fills up, instead of starting the next row over, it skips a row, so theres a huge gap between the 2 rows. I can manually move them closer, but even then, new icons still skip that row. Just out of curiosity, I kept downloading files to see what would happen when yet another row began, and that row began in the proper place. I've tried changing from aligning them to the grid to not, to repairing permissions, etc...

    I thought I saw a mention in the 10.4.7 update about desktop icons, but it still happens. I took a screenshot to show what I'm talking about:

    [​IMG]
     
  2. mkrishnan Moderator emeritus

    mkrishnan

    Joined:
    Jan 9, 2004
    Location:
    Grand Rapids, MI, USA
    #2
    When you click on the desktop and then View -> Show View Options, have you got a "keep organized by..." option selected?
     
  3. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #3
    No I don't.... I tried checking and unchecking it to see if it'd do anything, but nothing... this is how the settings look in my View Options window

    [​IMG]

    Also another note- I've been having this problem for well over a month and a half or so, and about 2-3 weeks ago I reinstalled the OS and installed Bootcamp. After doing a completely clean install of OS X (no archiving of files or anything) the problem persisted.
     
  4. realityisterror macrumors 65816

    realityisterror

    Joined:
    Aug 30, 2003
    Location:
    Snellville, GA
    #4
    Is it possible that you have some invisible files on your Desktop?
    In Terminal:

    cd ~/Desktop
    ls -a

    Do you see anything that starts with a period?

    Also, can you recreate the problem in another user account?
     
  5. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #5
    the only hidden files that ls -a shows is .DS_Store

    I know it's just an indexing type file, so I deleted it, but it didn't help the issue. I switched over to a blank user account and the problem did not show up there....
     
  6. realityisterror macrumors 65816

    realityisterror

    Joined:
    Aug 30, 2003
    Location:
    Snellville, GA
    #6
    You can try deleting some preferences.
    In ~/Library/Preferences, delete
    com.apple.finder.plist
    com.apple.desktop.plist

    I think the second one will change your background to the default. After you delete them, log out and back in before trying again...
    If that doesn't do it, then I've got no clue :eek:
     
  7. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #7
    I I deleted those preference files and when I logged back in, I immediately went ahead and made my icons and icon text smaller.... and it still skipped a row. Then the fact that I made a change before doing anything else made me wonder.... so I put it back like it was, and it worked!

    I played around with it some, and apparently if I make the icon text 10pt instead of 12, it skips a row... if I leave it at 12 but just make the icons smaller instead, it works like it should.....

    very odd.... but at least it works now, thanks for the help!
     
  8. Fleetwood Mac macrumors 65816

    Fleetwood Mac

    Joined:
    Apr 27, 2006
    Location:
    Canada
    #8
    I was just able to reproduce the problem on my mini.. That is odd.
     
  9. elbirth thread starter macrumors 65816

    Joined:
    Jan 19, 2006
    Location:
    North Carolina, US
    #9
    Yeah, it makes me wonder if people just don't change the font size on their icons to have not noticed this... I see screenshots of some people's Macs that have really big icons, which seriously annoys me on mine. I like them small so I can fit more on there. I always have the first row visible when I have Firefox open, so when I download something I can open it easily without having to hide FF or use Expose to get to the desktop via F11...

    Having 12pt font versus 10pt isn't a huge deal, but I'd like to have it smaller and still function properly if I'd like.
     

Share This Page