Develop only for iPhone/iPod

Discussion in 'iPhone/iPad Programming' started by rajkbala, Aug 7, 2010.

  1. macrumors newbie

    Joined:
    Aug 3, 2008
    #1
    Hi All,

    Could any one tell me how to make app only compatible with iPhone/iPod and not iPad. I compiled my app update on 4.0.1 and is working fine on iPhone/iPod touch. I dont have iPad so cant test it, works fine on iPad simulator. App review team rejected the update as they said it is not working with iPad and my code is compiled as universal. Could anyone please advise me how to make app only for iPhone/iPod Touch and not universal.

    Thanks in advance.
     
  2. Moderator emeritus

    robbieduncan

    Joined:
    Jul 24, 2002
    Location:
    London
    #2
  3. thread starter macrumors newbie

    Joined:
    Aug 3, 2008
    #3
    I have tried that but they are still saying it's universal app, anymore suggestions. Thanks.
     
  4. macrumors 6502

    Joined:
    Jul 30, 2010
    #4
    Isn't universal by definition both iPhone & iPad? Why not just develop it as an iPhone app? You have to choose to convert your app to universal don't you?
     

Share This Page