Developing on PPC OS X 10.5.8

Discussion in 'PowerPC Macs' started by abbotkinneydude, Mar 22, 2012.

  1. macrumors member

    Joined:
    Mar 22, 2012
    Location:
    Venice, CA
    #1
    Hello everyone !

    First post here.

    I'd like to develop a simple music application (some sort of audio player that would fit in the dock).

    I did register for a developer account on apple.com but I can't find a version of xCode that's compatible with PPC 10.5.8.

    If anyone has a link, please post here. Thanks !

    My setups are MDD Dual 1.42 & MDD Dual 1.25.
     
  2. macrumors P6

    Intell

    Joined:
    Jan 24, 2010
    Location:
    Inside
    #2
  3. thread starter macrumors member

    Joined:
    Mar 22, 2012
    Location:
    Venice, CA
    #3
    Thanks ! I just downloaded the 3.1.4 Developer Tools - hopefully this is what I need.
     
  4. macrumors 603

    SkyBell

    Joined:
    Sep 7, 2006
    Location:
    Texas, unfortunately.
    #4
    Be sure to let us know when it's finished, I'll boot into my spare Leopard partition to try it out. ;)
     
  5. abbotkinneydude, Mar 24, 2012
    Last edited: Mar 24, 2012

    thread starter macrumors member

    Joined:
    Mar 22, 2012
    Location:
    Venice, CA
    #5
    So I downloaded and installed 3.1.4 on top of my previous 3.0 install (that came with the OSX Leopard DVD). Works fine so far.

    I also have to compile VLC to help the 2.0.1 release get rid of those red lines when running on G4s 10.5 w/ Radeon graphic cards (& others it seems) and it's important to hack the xCode install to make it working:

    QTsound compilation on X.5

    Download the MacOS10.6.sdk and get QTCaptureDecompressedAudioOutput.h from /Developer/SDKs/MacOSX10.6.sdk/System/Library/Frameworks/QTKit.framework/Headers/ and move it to /Developer/SDKs/MacOSX10.5.sdk/System/Library/Frameworks/QTKit.framework/Headers/

    Edit /Developer/SDKs/MacOSX10.5.sdk/System/Library/Frameworks/QTKit.framework/Headers/QTKit.h and add the

    #import <QTKit/QTCaptureDecompressedAudioOutput.h> where needed.



    So doing this now...
     
  6. thread starter macrumors member

    Joined:
    Mar 22, 2012
    Location:
    Venice, CA
    #6
    Lesson learned -> It seems you can't unzip xCode 3.2.6 unless you run 10.6. :mad:

    Will stick to xCode 3.1.4 for the moment.

    So to get back to that audio application to be 10.5 PPC compatible.

    I'd like to come up with a very simple player that extracts the audio files from either sound cloud or my own personal web hosting.

    Right now my stuff is on facebook :

    http://www.facebook.com/soundtrackspecialist

    The goal would be for everyone to just click on an icon app in their OS X dock and get the latest stream.

    I'll do a Google search but if anyone has an opinion about where to start (coding wise), I'm all ears.

    Thanks !
     

Share This Page