Diablo 1 - OS X

Discussion in 'Mac Apps and Mac App Store' started by maradong, Oct 17, 2003.

  1. maradong macrumors 65816

    maradong

    Joined:
    Mar 7, 2003
    Location:
    Luxembourg
    #1
    howdy,
    is there anybody out there ( oh yes i like that sentence ;-) ) who knows whether it is possible to play Diablo 1, yes, the old one, on Mac OS X?
    This is really important. I just found the version in a store for 5$ and couldn t resist :)

    any help would be greatly appreciated.
     
  2. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #2
    Sorry, no way. Blizzard ported iTune...AHM Diablo 2 to OS X (sorry, I am in a fever) and porting D1 to OS X is just like Apple would port Quicktime 4 for OS X.... see the point?

    D1 is by the way not as good as D2 by far. Luckily I have OS 9 on my G4 and can run oldies like Day of the Tentacle, Monkey Island, Carmageddon 2 :D
    Oh, BTW, why isnt this in Games discussion? hmm
     
  3. maradong thread starter macrumors 65816

    maradong

    Joined:
    Mar 7, 2003
    Location:
    Luxembourg
    #3
    oh jeez didn t think of the game section.
    for me it was like software. but I do think you re right.
    Can please an admin arrange that. Thanks.

    But there has to be a hack to get it to work under os x. it is just so important for me :)
    Btw, I don t like diablo 2 as much. It certainly is a good game, but still, I never played that much on D2 than on D1 ...
     
  4. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #4
    Oh well, there is a possibility - or not?

    I thought about using CLASSIC :)

    But classic doesn´t detect CD-ROMs, or has problems with it, no?
     
  5. maradong thread starter macrumors 65816

    maradong

    Joined:
    Mar 7, 2003
    Location:
    Luxembourg
    #5
    i really don t know as I have literally never installed classic support. Personnaly I think it s something broken. and broken software has no place on my system :/ If I will have to install it to be able to play thought, I will probably do so.
    I will try however to evoid it.
     
  6. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #6
    WTF? You consider OS 9 as broken?
    Well, I started with OS 8.6, and I considered my iMac a great machine. TODAY, OS 9 has become like Windows: unstable (relatively) and only useful for games...
     
  7. Dreadnought macrumors 68020

    Dreadnought

    Joined:
    Jul 22, 2002
    Location:
    Almere, The Netherlands
    #7
    I play Diablo 2 still under classic! So, I don't see why it doesn't work with Diablo 1.

    Is the D2 os X patch already official, or still under development??
     
  8. Stike macrumors 65816

    Stike

    Joined:
    Jan 31, 2002
    Location:
    Germany
    #8
    Two things result out of this post:

    1. Diablo 1 should run fine under Classic.

    2. Answer about the OS X patch:
    The OS X patch is final. Just make sure to patch Diablo 2 to version 1.09d before installing the OS X patch.
    There is an issue with Jaguar and the patch. You cant run it in OpenGL mode fluently, so you need to switch to 256 color mode to use it.
    The upcoming patch 1.10 (OS X only) solves this, also Panther solves this issue.

    If you can live with 256 colors, upgrade now, else, wait until Panther or patch 1.10 is released.
     

Share This Page