Did 10.4.6 break spel chek?

Discussion in 'macOS' started by coumerelli, Apr 11, 2006.

  1. coumerelli macrumors 6502

    Joined:
    Apr 7, 2003
    Location:
    state of confusion.
    #1
    I've noticed that in my mail.app and spell check (via right-click) in Safari no longer functions. I use this ALL THE TIME and the only major change to my system that may remotely have effected this would have been the update from 10.4.5 to 10.4.6. Has anyone else seen this? I certainly have all the necessary settings correct, so I'm stumped. Appologies if this has already been covered. I searched and googled and came up with nothing.
     
  2. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #2
    The spellchecker works fine for me in both of those apps. As does the 'check while you type' in Safari. I'm also running 10.4.6 on a powerbook.

    Cheers
     
  3. coumerelli thread starter macrumors 6502

    Joined:
    Apr 7, 2003
    Location:
    state of confusion.
    #3
    Maybe I need to just reboot - that's what I always tell my clients anyway. :eek: :cool:
     
  4. coumerelli thread starter macrumors 6502

    Joined:
    Apr 7, 2003
    Location:
    state of confusion.
    #4
    well, waddya know? a reboot did the trick. :eek: thanks for your reply, by the way, gauchogolfer.
     
  5. sam10685 macrumors 68000

    sam10685

    Joined:
    Feb 2, 2006
    Location:
    Portland, OR
    #5
    that's what i tell my family here that's new to Mac OS... "when in doubt, re-boot."
     
  6. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #6
    my spell check works erracticly now as well in 10.4.6.
    I have to quit the spellchecker (in terminal, 'killall AppleSpell') occassionally to get it working again.

    Any ideas on the cause? Reboot doesn't do the trick for me.
     
  7. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #7
    Hah wow... take as proof my spelling of erratically...
     
  8. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #8
    gamera~, what language do you have selected? You can work this out by CONTROL-CLICKING on a word in a text box and selecting Spelling from the Spelling menu. :)
     
  9. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #9
    I'm a little confused as to what you're referring to. When the spell checker dies for me, nothing works: all the items from the "Spelling" contextual menu (that pops up as result of a right/control-click on a word or text box) do nothing. Even though I have "Check Spelling As You Type" checked, misspelled words go unnoticed.

    It starts working again once I've killed AppleSpell.
     
  10. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #10
    Ahh, okay, so the entire process crashes...

    Umm, do you have another Mac or access to another Mac? There's a file named AppleSpell.service in the Services folder within your System's Library. This file sometimes corrupts but replacing it usually resolves most problems. If you don't have a Mac nearby, I can email you a copy of mine if you PM me your address. It's 8.6MB. :)
     
  11. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #11
    Yep, I've got an iBook nearby. Too bad though, I've added quite a few entries to the spell checker... foreign words/names and such that pop up occasionally in papers (chinese philosophy comes to mind.) Maybe it was using the "learn spelling" function often, coupled with 10.4.6 update that caused the corruption.

    Thanks for the help.
     
  12. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #12
    Who knows. Keep the old file because if this doesn't work, you might still be able to get your customisations back. :)
     
  13. gamera~ macrumors member

    Joined:
    Apr 28, 2005
    Location:
    Boston MA
    #13
    poking around, it seems to keep the customizations in ~/Library/Spelling/en
    so, shouldn't be a problem.
     
  14. coumerelli thread starter macrumors 6502

    Joined:
    Apr 7, 2003
    Location:
    state of confusion.
    #14
    It sounds like I'm not alone after all. Although I haven't had any problems since, I'll be on the lookout - that's for sure!
     

Share This Page