Disable 2G but leave 3G and LTE on

Discussion in 'iPhone' started by yjchua95, May 9, 2013.

  1. macrumors 604

    Apr 23, 2011
    GVA, KUL, MEL (current), ZQN
    Good day.

    Ever since I updated to iOS 6.1 a few months back, I've been getting lousy 3G reception. In places where I used to get around 3 bars of 3G, now I cannot even get 3G at all and the phone switches to 2G. Also, in places where I used to get around 4 bars of LTE, I can only get 2G signal now.

    Is there anyway I can disable 2G and force my iPhone to use 3G or LTE only? Without a jailbreak.

    Thanks in advance.
  2. macrumors 68020


    Jan 2, 2011
    Make sure you have 3G and LTE turned on. Possible that setting got switched off.
  3. macrumors 6502a


    Jun 15, 2010
    MN, USA
    You might be misunderstanding what's happening.

    Your iPhone isn't picking up a quality 3G/LTE signal and is grabbing the only consistent signal it can which is EDGE in your case.
  4. thread starter macrumors 604

    Apr 23, 2011
    GVA, KUL, MEL (current), ZQN
    It's always on.


    In the sweet days before iOS 6.1, I could get 4 out of 5 bars of LTE and full signal strength on 3G in my area. Ever since going to 6.1 (now 6.1.4), it's been crap all the way.

    So I know that my area has good LTE and 3G coverage. And now I wonder why does my iPhone keep using 2G in my area.

    Hopefully this'll get fixed in iOS 7 :D
  5. macrumors 68040


    May 31, 2007
    Florida, USA

    Your area might have HAD good LTE and 3G coverage, but something change in the network or environment such that the coverage is no longer good at your location.

    Can you receive LTE/3G elsewhere without issue?
  6. macrumors 68040


    Jun 21, 2010
    Your firmware update didn't cause you to loose service. That's ridiculous to even assume.
  7. macrumors G3


    Nov 29, 2011
    Boston, MA
    In order to actually answer the OP's question...

    Can't be done without jailbreak. Assuming you are jailbroken, download something like SBSettings. There should be an Edge toggle. If it's not there by default, mess around inside the settings (of SBSettings under more) and you should find it there.

  8. macrumors 6502

    Oct 18, 2012
    Sounds like the towers in the area are having problems. The problems may have started coincidently with your update. I would call your carrier.
  9. thread starter macrumors 604

    Apr 23, 2011
    GVA, KUL, MEL (current), ZQN
    Well, my classmates that are still on iOS 6.0.2 can get full 3G and LTE while I can't. And besides, I'm not the only one complaining about this. I've gone through the Apple Support Community forums and there's lots of iOS 6.1 users that complain about loss of 3G reception after updating to 6.1.
  10. macrumors newbie

    Dec 27, 2012
    Yup, this happened to me on my unlocked iphone on tmobile. On ios 6, I could 2-3 bar 3G, and it would be really easy to reconnect if I wash kicked back to edge. Once I got to ios 6.1, I was ALWAYS on edge, and could not establish a stable 3G.
    A temporary fix is to go to settings->carrier->automatic off. Then wait for it to load (about 1-2 min) then Click your carrier. It should work, but would need to be done every time you got kick back to edge
    This was way to much of a hassle for me, so I sold that iphone and picked up the new aws one when it came out.
    Hope this helps!

Share This Page