Disable Adobe Acrobat plugin in Safari?

Discussion in 'Mac Apps and Mac App Store' started by Fourbin, Dec 11, 2005.

  1. Fourbin macrumors regular

    Joined:
    Aug 28, 2004
    Location:
    Philadelphia, PA
    #1
    I recently purchased and installed Adobe CS2. With Acrobat Professional comes a Safari plugin that automatically views PDFs in the browser. However, I much prefer the standard Tiger PDF viewer as Acrobat takes forever to load. I've looked everywhere and can't figure out how to disable this feature.

    Can anyone help?
    Thanks!
     
  2. VanNess macrumors 6502a

    VanNess

    Joined:
    Mar 31, 2005
    Location:
    California
    #2
    I don't have CS2, but in Adobe Reader, opening preferences, selecting internet and unchecking "display PDF in browser using..." will revert Safari back to it's built-in PDF viewer.
     
  3. Fourbin thread starter macrumors regular

    Joined:
    Aug 28, 2004
    Location:
    Philadelphia, PA
  4. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #4
    This is an old thread, but it came in handy when I wanted to disable a new Acrobat installation and wasn't sure which program (Safari or Acrobat) had the appropriate preference setting.

    By the way, you must quit and relaunch Safari for the change to take effect.
     
  5. audio_inside macrumors regular

    Joined:
    Oct 7, 2003
    Location:
    Boulder CO
    #5
    Update

    Navigate to /Library/Internet Plug-Ins. You should see the AdobePDFViewerPlugin there. If you don't have one already, created a directory called Disabled Plugins. Move the AdobePDFViewPlugin there and restart Safari.

    Safari should use its embedded PDF viewer instead of Adobe. You can check Safari's Help->Installed Plug-ins menu to see that Adobe is no longer included in the list of loaded plugins.
     
  6. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #6
    It would appear that Adobe made some undesirable changes since the last post...

    In Adobe Reader's Internet preferences, I cannot deselect "Display PDF in browser using: Applications/Adobe Reader.app".

    Also, there are no plugins in my user's "Library/Internet Plug-ins" directory or any extensions listed in Safari preferences.

    I have Adobe Reader X version 10.0.0. Any thoughts? I'd really like to get the default reader back.
     
  7. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #7
    I have Acrobat 9 Pro and the checkbox is still there. It really annoys me that Acrobat enables this checkbox automatically, without my permission, every time I install an Acrobat update, even though I had previously turned it off. But at least the checkbox still works.
     
  8. EricNau Moderator emeritus

    EricNau

    Joined:
    Apr 27, 2005
    Location:
    San Francisco, CA
    #8
    It really annoys me that they took the check box away. ;) Well, it's actually still there, but I can't de-select it!
     
  9. blackketter macrumors newbie

    Joined:
    Dec 12, 2002
    #9
    Look in the top-level Library directory:

    /Library/Internet Plug-Ins/

    Then, as suggested, create a folder called Disabled Plugins there, drag the AdobePDFViewer.plugin to that folder and restart Safari.



     

Share This Page