Disable Airport on iBook G4

Discussion in 'PowerPC Macs' started by mlofoto, Jul 6, 2011.

  1. macrumors newbie

    Joined:
    Jun 27, 2011
    Location:
    Charlotte NC
    #1
    I have an iBook G4, 1.33mhz and am experiencing kernal panics upon startup. When I disable Airport using Safe-Boot through the terminal using:
    /sbin/mount -uw /
    cd /System/Library/Extensions
    mv AppleAirPort.kext /
    mv AppleAirPort2.kext /
    it will restart fine. Problem is this: When I shut-down the computer, the next time I restart, I have to start in Safe-Boot again, disable airport, and restart. Is there a solution to permanently disable airport?

    Thanks
    ML
     
  2. macrumors member

    Joined:
    Jun 16, 2011
    #2
    Remove the card or reinstall the OS.
     
  3. thread starter macrumors newbie

    Joined:
    Jun 27, 2011
    Location:
    Charlotte NC
    #3
    Removing the card is...do-able but difficult. You have to take the entire case apart and go all the way to the logic board. I have reloaded and upgraded the OS and it doesn't help..

    ML
     
  4. macrumors member

    Joined:
    Jun 16, 2011
    #4
    Looks to be a failed card if the OS install didn't fix it.
     
  5. misshelene, Feb 3, 2012
    Last edited: Feb 3, 2012

    macrumors newbie

    misshelene

    Joined:
    Feb 3, 2012
    Location:
    Ama'r, Copenhagen, Denmark
    #5
    I had the same problem. This is how i solved it.

    The model of iBook G4 i use is from mid 2005 so there is no option of removing the AirPort card since it's kinda hot-wired into the rest of the electronics.

    And there is no way of turning it off in OpenFirmware like on the BIOS on a PC.

    This is how i got it working.

    Start the machine in safe-mode.

    Start terminal.

    type "sudo -s" (and provide root/admin password - if any).

    Go to "/System/Library/Extensions" and delete every file having the dreaded "AppleAirPort*" in them... There usually is 2 or 3, named "AppleAirPort.kext", "AppleAirPort1.kext", "AppleAirPort2.kext", you get it.

    Just type "rm AppleAirPort*".

    Reboot your machine. That should do it. But every time an update installs those files simply delete them.. Works for me :)
     

Share This Page