1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Disable Hyper-Threading Mountain Lion 10.8 (Speed Up the Mac)

Discussion in 'OS X Mountain Lion (10.8)' started by mx1t, Dec 10, 2012.

  1. mx1t, Dec 10, 2012
    Last edited: Dec 12, 2012

    macrumors newbie

    #1
    Hi,
    I would like to disable HT from my MacBook Pro Retina running on 10.8 (Mountain Lion)

    I found some solutions on the Internet but they don't work or not enough for me :eek:

    On 10.7 (Lion) this solution works fine but doesn't on 10.8
    OFF: sudo nvram SMT=0
    ON: sudo nvram -d SMT

    The second works on Mountain Lion but it's not permanent.
    Install Xcode->Open Instrument App->Preferences->Disable Hardware Multi-Threading.
    It's not permanent unfortunately, after restating the Mac everything returns to normal.

    The last one (Last Hope :rolleyes: ) works but.....
    sudo nvram boot-args="cpus=4"

    This solution gave me 4 Cores at Activity Monitor (But I'm not sure if it's 2 Cores + 2 Threads or 4 Cores + 0 Threads)
    I beleive it's 2 Cores + 2 Threads because I felt the Mac little bit Slow.

    Now I'm looking for a permanent deactivation of HyperThreading on Mountain Lion.
    Help Please???? :(


    Edit: Why Disable HT From 10.8 ?
    When I disabled HT with Xcode Instrument, my Mac became tooo fast, all applications started fastly even Apple Video Editing apps like iMove and Final Cut Pro.

    Why permanent ?
    For Bootcamp Windows 7.
    I tried Assassin's Creed 3, works fine on rMBP but when I checked Ubisoft Forums, some users said that HT slow down games, also Ubisoft Recommend to disable HT.
     
  2. macrumors regular

    #2
    So, did you run some proper benchmark? Because applications are cached on the ram after the first time you launch them.
     
  3. macrumors newbie

    #3
    I know Ritsuka
    I did the test before the applications are cached on RAM. (restarting Mac)
    Try it by yourself, open Final Cut Pro or a 3D Application Like Autodesk Maya and start Rendering, you'll feel the difference.

    Do you have any solution to disable permanently HT on 10.8?
     

Share This Page