Disable Promiscuous Mode?

Discussion in 'Mac OS X Server, Xserve, and Networking' started by corywoolf, Nov 11, 2012.

  1. macrumors 65816

    corywoolf

    Joined:
    Jun 28, 2004
    #1
    Hi All,

    I haven't been able to get on my campus' network since the start of the semester, their IT team (low-level) couldn't figure it out after an hour of toying around. I can log onto the network from any other device, but it appears my MAC address might be blocked. I am in a networking class, so I was trying out WireShark on my home network awhile ago (I live alone but have plenty of devices running on the network) to see how it works. I tried running a command in the terminal to disable promiscuous mode, it said "bad value" for
    Code:
    sudo ifconfig en1 -promisc
    , so clearly I am missing something.

    Partial output for
    Code:
    sudo ifconfig en1
    is:
    Code:
    en1: flags=8963<UP,BROADCAST,SMART,RUNNING,PROMISC,SIMPLEX,MULTICAST> mtu 1500
    It appears PROMISC mode is turned on for my MacBook Pro's (10.8) built in WiFi (Airport). How do I disable PROMISC? I didn't see an option in WireShark.

    Also, no I am not trying to snoop on people. My professor mentioned WireShark in a lecture at the beginning of the semester in my computer networks class.

    Thanks in advance,

    Cory
     
  2. macrumors newbie

    Joined:
    Oct 8, 2014
    Location:
    New York City
    #2
    promiscuous mode

    Not too many folks have even heard of
    'prp mode". I have the opposite problem. I WANT to set up "pro mode", otherwise my wireshark only capyures packets from the computer it's installed on.
    How'd you do it?

    macbook pro mid 2010

    Thanks,

    fenton
     

Share This Page