Disabling internal display on Macbook

Discussion in 'OS X Mavericks (10.9)' started by gumblecosby, Jun 11, 2013.

  1. macrumors 6502

    Joined:
    Jun 22, 2010
    #1
    Since installing OS X 10.9 I have found that clamshell mode has reverted to behaviour found in Snow Leopard ie. you can disable the display and keep the lid open by sleeping the laptop and plugging in a usb mouse.

    Can anyone else confirm the same?
    Hopefully it wasn't a fluke as I prefer it this way.
     
  2. macrumors member

    Joined:
    Apr 19, 2010
    Location:
    Genoa, Italy
    #2
    Woww!
    Finally!! I'm looking forward to upgrade to Mavericks..
    I wanted this feature back! ;)
    Bye,
    Andrea
     
  3. macrumors regular

    AAPLGeek

    Joined:
    Nov 12, 2009
    #3
    This alone would make me want to upgrade as soon as it's released!
     
  4. macrumors 6502

    Joined:
    Aug 19, 2010
    #4
    Whaaaat I was just looking for a fix for this since the software I used in ML doesn't work with the 10.9 DP! turns out I dont need software ! :D EPIC! This combined with the option to have external displays through appleTV + airplay is awsome!
     
  5. macrumors member

    Joined:
    Apr 19, 2010
    Location:
    Genoa, Italy
    #5
    Installed 10.9 right now but for me it doesn't work... Maybe I do something wrong?
    When I put my 15" rmbp in clamshell mode, the second monitor immediately activates itself, but, as soon as I open my MB lid it activates again becoming the primary one. It doesn't stay off. :(
    Why?
    Maybe I need a thunderbolt display?
    My second monitor is connected with minidisplayport / vga adapter


    Bye

    Andrea
     
  6. thread starter macrumors 6502

    Joined:
    Jun 22, 2010
    #6
    Hmm. Im running 10.9 from an external usb drive. My main partition is 10.6.8 and I also run Lion with the pmset command I posted below so perhaps it is the reason it is working in 10.9.

    I am using a mini DVI to HDMI adapter to connect to the external display in case you are wondering what the setup is.

    Perhaps you could try the pmset command from this tip (Tip 1):
    http://www.cultofmac.com/176329/turn-off-internal-lcd-display-of-your-macbook-air-os-x-tips/

    The command (in case you don't want to visit that link I posted or work won't let you) :
    sudo nvram boot-args="iog=0x0"

    Restore to default with:
    sudo nvram -d boot-args or
    reset PRAM
     
  7. macrumors member

    Joined:
    Apr 19, 2010
    Location:
    Genoa, Italy
    #7
    Thank you so much gumblecosby...
    I thought that Apple reverted to the S.L. clamshell mode feature natively for 10.9!!
    I wouldn't apply any definitive change to my system... Simply it would have been so good to have back that feature without applying any command :-(

    Bye!

    Andrea
     
  8. macrumors 6502

    Joined:
    Sep 4, 2006
    #8
    I can't seem to figure this out. I did it once right after I installed Mavericks, but I'm not sure what I did and can't seem to get it to work again. Anyone else have any luck with this?
     
  9. macrumors newbie

    Joined:
    Oct 26, 2013
    #9
    It worked, then it didn't.

    I'm finding the same thing. It was working perfectly but after a few days it stopped.

    What I'm finding now is that I can't get just the internal monitor to turn off.

    Even if I close the clamshell it stays on. But then it attempts to sleep the computer every few minutes.

    :mad:
     

Share This Page