Disbale internetl speaker.

Discussion in 'Windows, Linux & Others on the Mac' started by nyzrox, Jul 12, 2006.

  1. nyzrox macrumors member

    May 24, 2006

    You need to find the section in the registry corresponding to the sound driver.
    It should be under here on all computers:


    Then beneath that there should be a load of sequential four digit numbers; each one of these is a multimedia driver. On mine the sound device driver was entry 0005 but it may vary on others. You need the one with value Driver = sthda.sys in it.

    Under that one, go to the \Settings\GPIO key.

    There should be two binary values with names 00 and 01. Both will be set to value 85. Change 00 so it is set to value 05 instead. Regedit should then look like:

    (Default) REG_SZ (value not set)
    00 REG_BINARY 05
    01 REG_BINARY 85

    Finally, go to Device Manager and disable then enable the "Sigmatel High Definition Audio CODEC" driver so that it reads the new configuration in.

    You should find that only the headphone/line out socket is enabled now, and sound to the internal speaker is cut.

    If anyone else tries this, please let me know if it works on your system!
  2. jambi macrumors newbie

    Jul 14, 2006
    Here's how to get your headphone jack to work like it's supposed to (internal speakers on until headphones plugged in, headphones working too):


    This worked on my 2ghz white macbook with Windows XP Pro Corporate.


    1. Uninstall Sigmatel audio driver from your system

    2. Install Sigmatel Audio driver v.5.10.4991:

    (If you get an error during install complaining that the "software isnt compatible with your board...bla bla bla", ignore this-its just referring to the Intel Audio Studio it's trying to install)

    3. make .txt file,open it and copy and paste this:

    Windows Registry Editor Version 5.00


    4. rename this file to lineoutfix.reg (make sure file extensions are not hidden in your system) and doubleclick it->yes.

    5. reboot.headphones works now

    6. open stacgui.cpl, located in ...Program Files\Sigmatel\C-Major Audio\STACGUI and switch to 'Rear Mic' under 'Recording Control'.Internal speakers works now

    thats all,both works and headphones mutes speakers

  3. iCeQuBe macrumors regular

    May 19, 2005
    Thanks! It has been so annoying not being able to mute the internal speakers.
  4. nyzrox thread starter macrumors member

    May 24, 2006
  5. ironic23 macrumors 6502

    Feb 8, 2006
    I tried the 2nd method posted here and now my microphone doesn't work. Does anyone know a fix to this? THanks.
  6. nyzrox thread starter macrumors member

    May 24, 2006
    Go into registry and delete the tage you created.

    then try my way if you use external speakers, try the way i listed
  7. ironic23 macrumors 6502

    Feb 8, 2006

    Your method doesn't work. After i disable and re-enable the sigmatel codec thing, the system says that the driver cannot be found. All audio is lost.
  8. ironic23 macrumors 6502

    Feb 8, 2006
    Now it works. I found out that i had an extra line in the registry and after removing that and having JUST the 3 lines as you said, it worked properly. Thanks.
  9. nyzrox thread starter macrumors member

    May 24, 2006
  10. mrskippy macrumors newbie

    Oct 7, 2007
    I followed #2 above, but the sound still is really, really faint coming out of the speakers. It almost sounds like it's coming from the jacks on the side, rather than from the speakers on the MacBook Pro.

    I've been trying to make this work for awhile now.

Share This Page