Disconnect from network share in Automator

Discussion in 'macOS' started by mikes63737, Jan 10, 2007.

  1. mikes63737 macrumors 65816

    Joined:
    Jul 26, 2005
    #1
    I recently made an automator script that connects to my server and downloads the files on there. However, I cannot get it to eject the share at all. How can I do this? I tried to use the "Eject Disk" option, but it didn't work.

    Here's my script:
     
  2. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #2
    The eject disk action will work, but you need to re-specify the server before you do it. So at the end of your workflow put the specify server (again), then put the eject disk action.

    That should take care of it.
     
  3. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
    #3
    That doesn't work.
     
  4. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
  5. GimmeSlack12 macrumors 603

    GimmeSlack12

    Joined:
    Apr 29, 2005
    Location:
    San Francisco
    #5
    Lame. Sorry I don't have any suggestions at the moment. Perhaps I can give it a shot tomorrow on my server's.
     
  6. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
    #6
    Don't worry about it... it's not a big deal. I would like to have it disconnect, but it isn't a big thing if it doesn't.
     
  7. applelabs macrumors member

    Joined:
    Jan 9, 2007
    #7
    It would be posable to do it using an AppleScript action in your workflow.
    I can't write one right now, but I'll do it tomorrow.
     
  8. mikes63737 thread starter macrumors 65816

    Joined:
    Jul 26, 2005
    #8
    Thanks! It works now.

    Code:
    tell application "Finder"
    	
    	eject disk "FILES"
    	
    end tell
     

Share This Page