DivX Pro 5.2.3 and .avi no sound

Discussion in 'Mac Apps and Mac App Store' started by meganb, Jan 29, 2005.

  1. meganb macrumors newbie

    Jan 28, 2005
    Hi all

    I have NO idea what I am doing here. I downloaded a couple of avi files from Limewire. One I put through DivX worked fine - vision and sound, the other - vision only.

    I have heards about something called codecs ... what are these, do I need them, if so where can I get them?

    PLEASE help if you can.


  2. BillHarrison macrumors 6502

    Jul 25, 2003
    Meg, it is my understanding that quicktime CANNOT play some types of sound encoding back via divx or xvid. I am not aware of why this is the case. There is a "repair" program that reads the divx, and rewrites it so it is playable for you. Here is the link:


    It takes the divx, and rewrites it (and quickly too, on my stock Mini 1.25ghz it took less than a minute) into a .Mov file, which then played back perfectly on my system, with audio, etc.

    I had the same problem you are, and this should fix you up. While I would prefer being able to simply play the divx movies, as I have my entire collection of DVD's ripped, this does work. And it does not modify the original divx, but makes a copy that has been modified, so you still have the untouched divx when your done.

    Thats the best solution i have so far, but I am a 1 week mac user, so perhaps those with more knowledge can step in with a better solution?

  3. meganb thread starter macrumors newbie

    Jan 28, 2005
    Thanks Bill. I found DivX Dr 11 only to discover PC lovin' boyfriend had already dloaded it and run movie through it. Seems the problem is with the movie anyway as other avis are now working ... AND the blasted thing is in SPANISH!!! lol. VERY VERY new at ripping here. Thanks again.

Share This Page