Do I need a plugin?

Discussion in 'Mac Basics and Help' started by ladyhawkjamaica, Oct 2, 2005.

  1. ladyhawkjamaica macrumors newbie

    Jul 24, 2005

    I just went to to play scrabble for the first time in over a year. Since I last went there I've added a SCSI hd and upgraded to OSx.3.5. First I tried SAfari, then Netscape, then Explorer. In the game lobby where you start a game I couldn't join a game or start a board or see myself on the player list with both safari and netscape. Explorer worked well enough to play one game, but still had similar problems.

    Do I need a plugin? Or should I upgrade to X.3.9? Or is my computer too slow? When I have some more $$$$ I will be upgrading to 500 Mhz G4, probably with a Sonnet card. Will that help?

  2. ladyhawkjamaica thread starter macrumors newbie

    Jul 24, 2005

Share This Page