Do you have to activate the iphone to use/jailbreak/unlock?

Discussion in 'Jailbreaks and iOS Hacks' started by gahwhatever, Sep 8, 2009.

  1. macrumors newbie

    I bought an iPhone at an Apple store and want to immediately jailbreak/unlock it. Does the phone have to be activated first?

    And if the phone is currently locked to Rogers (Canada), can it be activated at a US Apple store/ATT?
  2. macrumors 68030


    No, it shouldn't need to be activated first. Follow this to jailbreak:

    Install ultrasn0w and you'll unlock your iPhone.

    As for your second question, no. The device would be locked to Rogers and you would need to unlock via ultrasn0w and put in an AT&T SIM as far as I know.
  3. macrumors newbie

    Thanks. Actually I was wrong, I think it already was activated (someone bought it in Canada and shipped it to me, so wasn't sure what was going on with it). Currently jailbreaking with purplera1n.
  4. macrumors 68030


    Since purplera1n doesn't work with 3.0.1, I would recommend using redsn0w 0.8. :)
  5. macrumors newbie

    edit: Actually nevermind.
  6. macrumors newbie

    edit: nevermind for this as well
  7. macrumors 604


    Fallow the instructions already posted

    you update your iphone via 3.0.1 and Itunes you use redsn0w with 3.0 firmware to JB again link to tutorial here once you have Cydia you can connect to cydia via wifi and get Ultrasn0w most likley you will have to reboot to get it to recognize the sims.
  8. macrumors newbie

    Thanks just to clarify, in redsn0w I'm supposed to use 3.0 firmware? So not the 3.0.1_7A400 but 3.0_7A341?
  9. macrumors 68030


    Yah. :)

    You load 3.0.1 on your device, then you run redsn0w and when asked for the firmware, you actually point it to a 3.0 firmware instead.
  10. macrumors newbie

  11. macrumors 68030


    Try it all again? :) The unplug and then replug should work. :)
  12. macrumors newbie

    Hey, thanks for your reply

    I restored again using Itunes then tried redsn0w again. It's still stuck on "Waiting for reboot." :(
  13. macrumors newbie

    Sounds so easy...............

    ................when you say it quickly ! Actually, redsn0w is easy, I have run it about 100 times now, joined 12 forums like this one, downloaded firmware so many times, read 100's of guides to jail breaking and unlocking, DFU the phone so many times about wore the buttons out, and still can not get a signal ???

    And why, in all those guides, no one mentions activating or SIM card ( in or none )????

    It is 3G iPhone with 3.0, the problem is after redsn0w, go to Cydia, the sources section is blank, absolutely no content, try adding ultrasn0w url and get about 12 proxy errors. I have the proxy in settings, and also enter user name & password for Cydia to kick off, but still no joy, Wi-Fi signal is very strong.

    And while I am here, it surfs fine on Safari, but weather and stocks do not load, why is that? Don't they access via Wi-Fi first?

    Thanks for reading my moan, and maybe replying, John

Share This Page