Does xcode 4 work on Lion Preview?

Discussion in 'Mac OS X Lion (10.7)' started by ajvizzgamer101, Feb 28, 2011.

  1. macrumors 6502a

    Joined:
    Mar 3, 2008
    Location:
    United States
    #1
    I saw someone put on the "App compatibility table" that xcode 4 does not work on Lion Preview. I just want someone who has attempted to use xcode 4 for Lion to confirm or deny it.
     
  2. macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    Idaho
    #2
    I have not tried it. But if you have a developer account, go get xcode 4.1. It requires Lion so I imagine that it is relatively stable in 10.7. That does depend on having a developer account though....
     
  3. thread starter macrumors 6502a

    Joined:
    Mar 3, 2008
    Location:
    United States
    #3
    I have the iOS Dev account and we are in the process of making a Mac app. This week we decided that we will be buying the Mac Dev account to continue working on the app and check out Lion. I just wanted to make sure xcode 4 works. So xcode 4.0 doesn't work but 4.1 should work? thanks for your help :)
     
  4. macrumors regular

    Joined:
    Feb 27, 2011
    Location:
    Idaho
    #4
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148a Safari/6533.18.5)

    Yes Xcode 4.1 is designed for lion. However, you could just use snow leopard since it's more stable. Though, developing for lion gives your app potentially more features
     
  5. thread starter macrumors 6502a

    Joined:
    Mar 3, 2008
    Location:
    United States
    #5
    We want it to feel like a Mac OS X 10.7 app. Fullscreen mode, overlay scroll bar...ect
     
  6. macrumors member

    CarsonGallo

    Joined:
    Jun 14, 2010
    Location:
    Oakdale, New York
    #6
    Fullscreen Mode

    O sweet 3rd partys can enable the full screen mode built into lion. Sweet. Speaking of which I wonder when the Mac App updates are gonna start happening. Since we have the Mac App Store, just like in iOS some apps get update for beta os's before the new os is even out. Like StreamToMe which supports iOS 4.3, which should be coming soon hopefully. But surprisingly StreamToME has been the only app to get iOS 4.3 beta support so far, and that was a month ago. Hopefully well see apps that generally don't support full screen mode get it when they're updated for Lion support.
     
  7. macrumors newbie

    Joined:
    Oct 26, 2007
    #7
    The official XCode 4 release does NOT work in the Lion preview.

    jorj
     
  8. macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl
    #8
    Software development for Lion and/or iOS 4.3 (within Lion) requires Xcode v4.1 GM 2.
     

Share This Page