Doom 3 Macbook Help

Discussion in 'Games' started by ssheriff, Aug 18, 2006.

  1. ssheriff macrumors newbie

    Joined:
    Aug 18, 2006
    Location:
    Doncaster UK
    #1
    can you help?
    i have doom 3, just bought from my apple store and i have the latest patch including the UB update. i have sound on everything within my macbook, itunes web etc.
    but every time i launch the the game there is no sound, not with the built in or headphones connected.
    am i missing something? does the macbook or OSX have a "sound within games switch?"

    Confused

    Steve
     
  2. ssheriff thread starter macrumors newbie

    Joined:
    Aug 18, 2006
    Location:
    Doncaster UK
    #2
    Also to note, ignoring the lack of sound the game plays well. no issues with graphics on mediocre settings.

    Thanks

    Steve
     
  3. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #3
    Check the Audio section in the game settings. I know the sound is very very quiet at the start, then when you play it, it gets louder.
     
  4. ssheriff thread starter macrumors newbie

    Joined:
    Aug 18, 2006
    Location:
    Doncaster UK
    #4
    i have, volume to max and speakers on stereo. its all i can change i think.

    Steve
     
  5. slooksterPSV macrumors 68030

    slooksterPSV

    Joined:
    Apr 17, 2004
    Location:
    Nowheresville
    #5
    Make sure you can hear Audio files or something audible wise. If that all checks out... Make sure your software and firmware is all up to date. And... repair permissions that's all I can think of.
     
  6. Striderdm1 macrumors regular

    Striderdm1

    Joined:
    Oct 24, 2003
    Location:
    England
    #6
    Is safari open when u launch D3?
    I sometimes (not always) get no sound from d3 if safari is still running. Worth a try anyhow..
    thx, Strider.
     
  7. dextertangocci macrumors 68000

    Joined:
    Apr 2, 2006
    #7
    I had the SAME problem!

    If you hold down the option key (I think) while you click on the doom 3 icon, an advanced preferences window will come up. Fidlle with the sound options their and you will eventually come right.

    Sorry if I haven't given a proper explanation, I'm extremely tired and am going to bed now:eek:
     
  8. ssheriff thread starter macrumors newbie

    Joined:
    Aug 18, 2006
    Location:
    Doncaster UK
    #8
    thanks sofar.....

    Thought of those points folks, so i run with nothing else running at all.

    I have held the option button to bring up the setting box, chose OPEN AL. that is the only way to get any sound BUT.......
    (there is always a but)

    This seems to work great, ive spent the last day progressing thru the game until i got to the part of the game where the spiders are introduced.

    If I have 2 or 3 spiders to fight there is no problem. But as the come in number, I'm shooting them and more of them attack, suddenly the game crashes/quits. no warning straight to desktop.
    Bizarre??

    The punch line? Well, if I launch the game with out OPEN AL selected, (ie on my mac it plays fine but with no sound at all)
    those spider parts of the game are completely play able.
    Its like the computer crashes under pressure of dealing with those parts of the game while running OPEN AL.

    Wow, i think i've covered the story so far.

    PS, i have checked my ram under the Memtest App and as far as i i can tell its in good order, never crashed etc

    Help,

    Steve
     

Share This Page