Doom 3 on 10.4.8 - Intel Mac - No audio?

Discussion in 'Games' started by nagromme, Oct 3, 2006.

  1. nagromme macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #1
    I don't get audio in Doom 3 (patched to UB 1.3revA) on my 24" iMac. Great framerates in high def.... no sound :eek:

    Is this a new 10.4.8 issue maybe? Anyone else have this problem?

    (I DO get audio if I use advanced mode to enable the preview version of OpenAL--but that's messed up in its own ways and isn't really usable for me.)
     
  2. nagromme thread starter macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #2
    Quick fix: headphones/external speakers

    I think the OpenAL issues may be known: Aspyr's 1.3 readme refers to that feature as a "preview" and says there may be glitches/dropouts. (Though they don't mention the exits-to-menu.) Hopefully that "preview" will become "final" :)

    Meanwhile, I did report the issue to Aspyr and was sent a fix (which sounds like it is for Quake 4 too):

    "The no sound with Doom 3 issue can be resolved by changing the default bit rate in your Midi Setup from 2ch - 24bit to 2ch -16Bit.

    To do this, open the Audio Midi Setup control panel in the Applications/Utilities folder.

    Change Properties For: to Built - in Output. This will show you the Output options. The sample rate should be at 44,100hz, but the Bit rate is defaulted to 2ch - 24bit. Change that to 2ch -16Bit. Once this is changed, Quake 4 should have sound from the internal speaker without having to plug in speakers or headphones."


    Unfortunately that won't work for me: there ARE no Properties you can change for Built-In Audio on my 24" iMac. The Audio Output pane is blank except for the words "Output is not supported." There is nothing clickable on the right side of the window except for the Default Output and System Output popups at top-right, both of which are set to Built-In.

    I've tried with headphones now (OpenAL off) and the game sounds fine: so the problem is specific to the built-in speakers. I have followed up by email with Aspyr since there are times when I'd rather not have to wear headphones, but for now they (or external speakers) are my fix :)

    PS, I'm also wondering: would that 16-bit setting, if it were available, potentially reduce the output quality of any other apps I might use?
     
  3. nagromme thread starter macrumors G5

    nagromme

    Joined:
    May 2, 2002
    #3
    OK, Aspyr's tip DOES work. They emailed me again with more clarification. The Audio/MIDI "Properties For" pop-up on the left side--the INPUT side--contains the OUTPUT stuff too, which then shows up on the right. I won't comment on Apple's UI choices in this matter :) Just change "Built-in Mic" to "Built-in Output." Then follow the italicized tip above.
     

Share This Page