Double sided printing on Canon MP610 (solved)

Discussion in 'Mac Accessories' started by akarlsen, Nov 5, 2008.

  1. macrumors newbie

    Nov 5, 2008
    Hi everyone,

    I've converted from Vista to the new Macbook and have run in to a problem with my printer (Canon MP610). One of the functions I used often in Vista was the double sided printing function. After installing the latest Mac drivers from Canon's American homepage I get a lot of printing options on my mac, but under layout the double sided printing option is marked grey and I'm unable choose this option.

    Have anybody noticed something similar using a canon printer? Any ideas concerning how to fix this?


    By the way the new Macbook is great =)
  2. macrumors 6502


    Jul 28, 2006
    I've just got a new MP610 today, and installed the software from the supplied CD. The duplex option is working fine for me. When I get to the print dialogue box, there is an option box about half way down, and I choose "Duplex Printing & Margin" from the list. I can then tick a box that says "Automatic Duplex Printing", and it prints double sided.

    Are you getting the same options?
  3. thread starter macrumors newbie

    Nov 5, 2008
    Yes, I have the same options. Just didn't even consider entering the option you gave, the double sided printing option seemed to be the correct box.

    Thank you! :-D
  4. macrumors newbie

    Apr 23, 2008
    Rushmere, thanks for helping out your fellow forum members. You really saved me (after about a half hour of googling). You rock.
  5. macrumors newbie

    Oct 1, 2010
    Is there any way of printing double sided by default? I'd also like to change the default print quality from normal to draft. It seems a bit awkward having to set these on every single print job, but I can't see any way of changing the default settings.
  6. macrumors newbie

    Jul 21, 2011
    Another Barrier to Duplex printing

    I have just updated to Yosemite and the first document I tried to print on my MP610 didn't have a duplex printing option. I found out that the reason was that glossy photo paper was selected (The last thing I had printed was a photo). Worth checking if you have the same problem.

Share This Page