Double whammy?

Discussion in 'Mac OS X Lion (10.7)' started by grant.smith, Jun 8, 2011.

  1. macrumors newbie

    Joined:
    Jun 6, 2011
    #1
    I have just realised that Lion only works on Core 2 Due Mac's, I'm not sure, but I think my Mac at home is a Core Due 4.1, although it could be a 5.1/2.

    I am also MobileMe customer, am I right in saying iCloud only works with Lion?

    So not only can I not upgrade, I also will no longer be able to sync my iPhone with my older Mac.

    This sucks !!!
     
  2. macrumors 603

    Joined:
    Sep 19, 2003
    #2
    You can still sync with your iPhone, you just can't take advantage of the iCloud automatic sync. But iTunes Sync will work.
     
  3. thread starter macrumors newbie

    Joined:
    Jun 6, 2011
    #3
    Great, so essentially I have paid £59 a year for 9 years to be a beta tester to a service I can not use
     
  4. Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Missouri
    #4
    No. You have paid to use the service for 9 years. You understood what services were offered and there were no promises of extras or soon to come features that you never got.

    Technology moves on, it's part of life.
     

Share This Page