Download for mail 1.2.5 (v552)

Discussion in 'Mac Basics and Help' started by Mudbugfish, Sep 28, 2005.

  1. Mudbugfish macrumors member


    Apr 1, 2005
    Manchester UK

    I'm updating my old G3 which is running on OS X 10.1.5, I want to update Mail to 1.2.5 (v552). (It has 1.1 v481/482 on it now).

    Can anyone recommed a download for this? I'm I doing the right thing? Or should I go for another mail prog. Just that was use 1.2.5 on two other iMac's in the house.
  2. alex_ant macrumors 68020


    Feb 5, 2002
    All up in your bidness
    Mail updates are always packed in with the OS updates. If you want your old G3 to be running the same version as your iMacs, you either need to copy the version of Mail that's on the iMacs to the G3 (which might not work) or upgrade the G3 to the same OS version as the iMacs.
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    I personally wouldn't recommend using a version of Mail that wasn't bundled with the specific OS you're using since the app is so heavily imbedded in the system. :)

Share This Page