Downloading Books on CD to iTunes

Discussion in 'Mac Basics and Help' started by rogerthat, Nov 19, 2007.

  1. macrumors member

    Joined:
    Jun 14, 2007
    #1
    This has happened more than once. I get an audiobook on CD's from my local library and when I load the CD's they each contain upwards of 90 tracks ranging in length from a few seconds to a few minutes. They are recognized only as track 1, track 2, etc. and there are about 10 discs per book. If I load them all, I have 10 track 1's then 10 track 2's and on and on. Can't listen that way or load to iPod without exhaustive collating. I'm stumped.
     
  2. macrumors regular

    Joined:
    May 14, 2007
    #2
    When you insert the CD, before you import it , select all the tracks that are part of that book, and select Join CD Tracks from the Advanced menu. Also, you want to select either before or after the import to Make Track Bookmarkable. Now import and all the tracks will be one long track, and iTunes or your iPod will remember your place. I haven't done this for a while, so I'm assuming the newer iTunes is the same as it was.

    The only problem I sometimes have is that iTunes will only recognize certain books as audiobooks and take them out of my library - still looking for a fix for that. But some books it recognizes and does the correct filing.

    Hope that helps.
     
  3. macrumors regular

    Joined:
    May 14, 2007
    #3
    I found this under another post, great instructions from RumMunkey for getting your imports in the audiobooks library.

    Yes.

    The file has to be an AAC for starters, so if you've imported it as say, an MP3, first convert it to AAC by setting your import options to AAC then right-click on your file(s) and take "Convert to AAC".

    When done, right click on your file(s) and select "show in finder". When you see them in finder, drag them to the desktop, then delete any trace of them (and your originals) from iTunes (send them to the trash).

    Now you've just got some AAC files on your desktop.

    Change the extension of each file from "youfilename.m4a" to "youfilename.m4b". Click thru the warning... you do indeed want to do this.

    When done all the files in this particular book, drag them back into iTunes. Voila; they are in the Audiobooks section.
     
  4. thread starter macrumors member

    Joined:
    Jun 14, 2007
    #4
    Thanks

    I tried your suggestions and it worked like a charm. I couldn't find the "allow bookmark", but I'll work with it. I haven't tried getting it into audiobooks yet, either, but just getting it into my iTunes in a workable file is huge. Thanks so much for taking the time to help.
     
  5. Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #5
    It's the "remember playback position" checkbox.

    B
     
  6. thread starter macrumors member

    Joined:
    Jun 14, 2007
    #6
    Can't find it

    I have looked everywhere I can think of, but can't find the "remember playback position". I'm using the 7.5 version of iTunes.
     
  7. Moderator

    balamw

    Staff Member

    Joined:
    Aug 16, 2005
    Location:
    New England
    #7
    Get Info -> Options tab.

    B
     
  8. thread starter macrumors member

    Joined:
    Jun 14, 2007

Share This Page