downloading problems in safari v73

Discussion in 'Mac Help/Tips' started by anneleonard, May 28, 2003.

  1. anneleonard macrumors regular

    Joined:
    Mar 21, 2003
    Location:
    Reading, UK (a.k.a. Strongbadia)
    #1
    I don't seem to be able to complete *any* downloads in the new safari build, I end up having to download them in camino. They either seem to go very slowly, or even time out. One was unable to mount the disk image even though it had downloaded successfully. Is anyone else having these problems or is it just me?
     
  2. edesignuk Moderator emeritus

    edesignuk

    Joined:
    Mar 25, 2002
    Location:
    London, England
    #2
    The current public release build is Beta 2 v74, update to that and see how you go.
     
  3. anneleonard thread starter macrumors regular

    Joined:
    Mar 21, 2003
    Location:
    Reading, UK (a.k.a. Strongbadia)
    #3
    I got the version wrong, I'm actually using v74, that's the one that's messed it up for me.
     
  4. King Cobra macrumors 603

    Joined:
    Mar 2, 2002
    #4
    Remember, first and foremost, Safari is a BETA, not a reliable internet application.

    Whether Apple or some 2-bit company developed a beta of ANY type, there is always the chance of mishaps.

    Since you have the latest version of Safari, I would suggest downloading an earlier version (start with v62 and work your way up to more modern updates) and see if any of those updates work. If not, use something else.
     

Share This Page