DP2 Update 2 & Core Duo

Discussion in 'Mac OS X Lion (10.7)' started by tsmith, May 12, 2011.

  1. macrumors newbie

    tsmith

    Joined:
    Mar 27, 2011
    #1
    After updating DP2, Lion won't boot on my MBP Core Duo. I know for the first DP you had to remove platformsupport.plist and it was good to go. But now it seems DP2 updated doesn't work with that trick.

    I've been searching around but cannot find anyone else who has mentioned this issue who also has a core duo.

    Does anyone have any information on this or what to do to make it work on Core Duos again?
     
  2. macrumors 68040

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    You're better off asking in Apple's developers forum as those will be the people with the DP releases. There won't be many here to help you.
     
  3. Morris, May 14, 2011
    Last edited: May 14, 2011

    macrumors regular

    Joined:
    Dec 19, 2006
    Location:
    London, Europe
    #3
    OS X Lion officially requires a Core 2 Duo processor or newer. In other words, Lion only runs on 64bit capable Macs.

    The chances are that during development more and more components of the Lion builds are being optimised and compiled for 64bit only. You may have just been lucky for DP1 but that for DP2 some vital components are now 64bit only. Your 32bit CPU won't have a clue what to do with those binaries and it crashes trying to load something it will never be able to execute.
     

Share This Page