DP4 Installer Hang

Discussion in 'Mac OS X Lion (10.7)' started by scmaster53, Jun 6, 2011.

  1. macrumors newbie

    Joined:
    Mar 18, 2010
    Location:
    North Adams, MA
    #1
    Just downloaded and attempted to install DP4 on my 2010 MacBook Pro. I was watching the installer log and soon noticed that it was hanging on this

    Jun 6 20:32:18 cpe-67-252-43-84 OSInstaller[331]: FileURLGetDYLDEntryPointWithImage(/System/Library/PrivateFrameworks/Librarian.framework/Librarian,LBGetAttributeValueForItem) failed

    It would do this over and over again. I even reached the point where the installer window was telling me that I had "-2 minutes" to go.

    Did anyone else have this issue? Thankfully I have win7 installed on this computer also. Im going to attempt to insert my SL disk and see if I can run some disk repair on my HD from there.
     
  2. macrumors newbie

    Joined:
    Mar 2, 2009
    #2
    I've had the installer issue you describe on DP1,DP2 and DP3 on all three of my machines: iMac 2010, Macbook 2008, Macbook Pro 2009.

    I'm reluctant to try DP4 now...
     
  3. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #3
    Trying to clean install lion dp 4 from SL on macbook pro 2011 15".
    DP 4 installer hangs after first reboot –*trying to show installer.app window with progress bar and hangs.

    Any ideas ?
     
  4. macrumors 68000

    Joined:
    Mar 6, 2008
    #4
    sigh, again? I don't know why we have to suffer through this, I'm going to have to mirror my hard drive to an external one and see how it goes, I'd hate to break my Primary OS X Lion Hd, having to reinstall is a pain..
     
  5. macrumors member

    Joined:
    Oct 24, 2007
    #5
    Same for me - it hangs after the first reboot (macbook pro 2011)
     
  6. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #6
    Seems it is an issue on macbook pro 2011 – I was suspecting my ocz ssd drive in hanging (later there were difficulties to install snow leopard until ocz rolled out a new firmware).
     
  7. macrumors member

    Joined:
    Oct 24, 2007
    #7
    Actually, I run into this problem after system update for the macbook pro. I already had DP2 installed at the time and counldn't load it anymore (it would hang just like DP4 installer hangs now)
     
  8. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #8
    DP3 worked fine with IO80211 kext from DP2.
    DP3 failed to boot after an installation, but there were no any troubles with installing itself.
     
  9. macrumors G4

    daneoni

    Joined:
    Mar 24, 2006
    #9
    I can't believe there are still problems with the 2011 machines. This thing is shipping next month!
     
  10. macrumors regular

    RamGuy

    Joined:
    Jun 7, 2011
    Location:
    Norway
    #10
    I'm also facing installation hang on my MacBook Pro 2011 model..

    First it started of with hanging right after rebooting on the spinning circle beneath the Apple logo. So I attached my external hard drive containing the Mac OS X Snow Leopard Recovery DVD and I did a hard drive repair and permission repair and tried to install again and this time it manages to get past the spinning thingie but now it hangs the very same second the "Installing" window shows up, my cursor is stuck in the top left corner.

    Nothing I can do it seems, I did also try to clone the installation over on an external hard drive but it hangs the very second the installation process is about to begin..


    First it though this might be because I have replaced my superdrive with another SSD and running RAID0. But it seems like I'm not the only one facing problems?
     
  11. macrumors regular

    Joined:
    Feb 28, 2011
    Location:
    Shanghai, China
    #11
    Same here DP4 on iMac 2.8 GHz Intel Core 2 Duo processor ... first try hanging and later on message saying install error try restart and install again... same story. This time did not even start installing but hanged at "preparing to install" screen.

    All Ok on MacBook pro 17''

    What's happening?
     
  12. macrumors newbie

    Joined:
    Feb 10, 2007
    #12
    Same Problem! Freeze after Reboot and Installer launch. Now how can we get back to our old 10.6 system? It also freezes when I boot up my snow leopard install cd. Here it freezes with the black apple "bluescreen" and some terminal commands in the background...
     
  13. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #13
    Here is my screenshot – install hangs after the first reboot:
    [​IMG]

    with cinema display removed – sometimes first install windows appers with the progress bar.
    This is not SSD problem - I've tried to install onto 16GB Usb stick.
     
  14. macrumors regular

    Joined:
    May 14, 2011
    #14
    Tried several ways to install DP4. Clean install, update on DP3, update on SL, ... always the same result. Freezes after first boot.
    Sometimes got a corrupted Apple logo boot screen but freezes nevertheless.

    Macbook Pro 2011

    Could well be a Appstore protection. If you don't officially download it from the Appstore it will not work.

    Also, shame it will not be released on DVD

    EDIT:
    Wondering : why only 4GB? I mean, every full update DVD for Leopard and SL are at least 6GB.
     
  15. macrumors newbie

    Joined:
    Jun 7, 2011
    #15
    Same issue, macbookpro8,2, similar screen corruption to raveman. If I hold down shift I can boot into dp2, which I had on it before trying to upgrade. Sometimes it gets slightly further than the screen corruption, sometimes it doesnt even reach that.

    Reseting smc, nvram, etc, did not help.

    So annoying, dp3 didnt run either on this machine.
     
  16. thread starter macrumors newbie

    Joined:
    Mar 18, 2010
    Location:
    North Adams, MA
    #16
    I was able to successfully get DP4 to install after I powered off the machine and ran disk repair/verify from my 10.6.3 SL DVD. I booted back into Lion and it recovered the installation and continued to hang on the same line. Then by some miracle it stopped and started extracting the core .pkg's from the SL DVD that was still in my opt drive. It then began copying them into the OS 10.7 installation and proceeded to finish up the install just fine. I'm now rocking DP4 and its pretty sweet.

    I have no idea why it extracted the .pkgs from the SL DVD though...
     
  17. inf
    macrumors 6502

    inf

    Joined:
    Nov 22, 2006
    Location:
    Helsinki, Finland
    #17
    This is what I get if i try to install Lion DP4 (i'm now on dp3) at the moment (the attachment screenshot)
     

    Attached Files:

  18. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #18
    I don't understand, what exactly is needing to be fixed? All partitions seems to be okey (booting installer in single mode and running fsck and other stuff).
     
  19. macrumors newbie

    Joined:
    Jun 7, 2011
    #19
    I dont think he has the same installation issue we are having raveman. Hes on a different machine and he gets to the installer, we dont even get that far, we only get that screen corruption.

    It appears that the macbookpro8,2 doesnt play with dp4, I havent found any work around yet.
     
  20. macrumors regular

    Joined:
    May 14, 2011
    #20
    Maybe DP4 can only be updated from DP3?

    Anyway, I cannot believe so many people having issues with DP? and the latest MBPs
    Apple must be aware of this right?
     
  21. thread starter macrumors newbie

    Joined:
    Mar 18, 2010
    Location:
    North Adams, MA
    #21
    Im on a 15inch 2010 Macbook Pro (Core i7 model). It seems that the 2011 models are still bugged to heck and back when it comes to DP4
     
  22. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #22
    I have strange feeling that there are problems with ATI/Intel cards and on-fly switching, which are in 2011 models. What if to delete or get from DP3 corresponding kexts ? (like with the wifi cards)
     
  23. macrumors newbie

    Joined:
    Jun 7, 2011
    #23
    Have you tried the wifi kext thing? I was about to try that...
     
  24. macrumors newbie

    Joined:
    Jun 7, 2011
    Location:
    Russia
    #24
    Yes, wifi was the first thing which was deleted. But there was no any kernel panics while booting. Only when switching to graphics mode system hangs.
    Unfortunately I have no DP3 installed and I can't check this for now.
     
  25. macrumors newbie

    Joined:
    Jun 7, 2011
    #25
    Lol, got it booting. Heres what I did:

    1) Took a second macbook pro (non early 2011, an older model), booted it from a lion dp4 DVD i made.
    2) Hooked up my macbookpro8,2 (early 2011) and booted it in target disk mode, installed DP4 from the older macbook pro onto the new macbook pro via the firewire cable.
    3) Followed the IO802 kext removal instructions from here: http://forums.macrumors.com/showthread.php?t=1145144

    Notebook now boots (without wifi support).

    Now I'll run the kext replacement instructions from http://forums.macrumors.com/showthread.php?t=1145144 to get my wifi back.

    Yeay! :D
     

Share This Page