drive won't mount yet I can repair it.

Discussion in 'Macintosh Computers' started by blue&whiteman, Apr 13, 2004.

  1. macrumors 65816

    blue&whiteman

    Joined:
    Nov 30, 2003
    Messages:
    1,210
    #1
    yet another problem with my wd drive. if it wasn't for this being a gift from my wife I would drop kick it out the window.

    last night I decided for once to shut my computer off for the night. I woke up and booted up after I made some coffee. it started up normal till it got to the progress bar part of the startup. at this point everything was going really slow and about 3 min later it finally was done booting. I started up firefox and my system froze. I figured it would be the same old problem where all I have to do to solve it is unplug its data and power then startup without it connected then shut down again and startup once more. this usually solves it but this time no. I even tried going from cable select to master/slave settings since its on the cable with another drive.

    finally I got techtool pro 4 to see the drive and repair the volume structure but it still won't mount when I startup. what would happen that would let a system see and fix a drive but not mount it. both ttp4 and disk util. mount option won't work.

    if it wasn't for my other drive also having an os on it my computer would be useless right now. there is so much stuff on the wd drive that I can't afford to lose.

    any feedback would be great.
     
  2. macrumors 65816

    blue&whiteman

    Joined:
    Nov 30, 2003
    Messages:
    1,210
    #2
    i'm starting to think a reformat is my only option.

    the really odd thing in all this though is that the drive does not mount yet disk utility sees it fine. it shows the drive but the volume name under it is grayed out.

    I will take any ideas anyone has. anything...
     
  3. macrumors 68020

    Horrortaxi

    Joined:
    Jul 6, 2003
    Messages:
    2,243
    Location:
    Los Angeles
    #3
    Me too.

    I had this happen with somebody else's iPod. The owner habitually unplugged it without unmounting it and eventually screwed it up. Naturally all his music was only on his iPod (why do people do that?) so a simple reformat was a last resort. The drive wouldn't mount but Disk Utility could see it. I made an image of the drive and then refotmatted. The image had the same damage the iPod did, but it would mount. Most of the data was then recoverable.
     
  4. macrumors 65816

    blue&whiteman

    Joined:
    Nov 30, 2003
    Messages:
    1,210
    #4
    my drive is internal so this is not from unmounting it wrong. I can't make an image of it either as the drive that is down is 120gb and the working one is only 6gb.

    any other ideas? I only want to reformat if there is no other way. there is about 40gb of data n it that I need badly. guess this is my fault for not backing up. thats the problem when you have a large drive. you get lazy because it fills up so slow that you don't backup data much.

    I will try any ideas. even risky ones as I don't have much else hope at the moment.
     
  5. macrumors 65816

    melchior

    Joined:
    Nov 17, 2002
    Messages:
    1,145
    #5
    DiskWarrior is the king of disk repair. I have also experienced the recognised but unmounting disk many times and diskwarrior has always saved the day. (except for the time i was using a fat32 formatted drive....)

    really, diskwarrior is a savior and worth owning.

    melchior

     
  6. macrumors 65816

    melchior

    Joined:
    Nov 17, 2002
    Messages:
    1,145
    #6
    oh, by the way. i forgot to mention the probable cause for this. corrupt directory structure and/or corrupt files. lots of things can do this. a bump, a faulty drive. a bad shutdown a program that crashed while writing to disk....

    diskwarrior will help, without question. do not get ready to format!
     
  7. macrumors 68020

    Horrortaxi

    Joined:
    Jul 6, 2003
    Messages:
    2,243
    Location:
    Los Angeles
    #7
    You said it, not me. :D Time for Disk Warrior.
     
  8. macrumors 65816

    blue&whiteman

    Joined:
    Nov 30, 2003
    Messages:
    1,210
    #8
    thanks guys. i'm going to get that app and see what comes about. sounds like it just may work.

    wish me luck.
     

Share This Page