Dual Displays in Mac OS X w/ 'Unsupported' PCI Card

Discussion in 'Macintosh Computers' started by LimeiBook86, Apr 13, 2005.

  1. LimeiBook86 macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #1
    I have a PowerMac G4 AGP (450mhz ATI 16mb AGP Card, 896mb RAM, DVD-R) setup to an old Apple 17 CRT inch display.

    The 17 inch display is VGA - It fits into the ATI Card perfectly and works fine. The second display is a 20 inch AppleVision 850 (old Apple style monitor plug, NOT VGA-thus not fitting into the currently installed ATI card) - I have the adapter to hook this monitor up but it's not here at the moment.

    Since I'm very impatient I popped in a PCI Video Card (with the old style Mac video plug connecter) into the G4 from my old PowerMac 9600. Now Dual Displays work fine in Mac OS 9.2.2, but in Mac OS X 10.3.8, the second display (in this case the 20 inch) just has a solid blue screen on it and the 'Displays' System Preference doesn't even see it there, but it can be seen in System Profiler.

    I'm wondering if there is any work-around I can do or something I can download or install, Mac OS X probably doesn't support the PCI video card so I'll go back to a single screen setup for now...

    ...But any help would be great. :D
     
  2. RGunner macrumors 6502a

    RGunner

    Joined:
    Jul 3, 2002
    Location:
    Midnight Sun
    #2
    Is your old card a TT128 (twin turbo 128)?

    this is an unsupported card in OSX 10.3.8 no matter what you do.

    if a rage, it should come up under 10.3.8.

    let us know what the old 9600 PCI card is.
     
  3. LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #3
    The ATI Card is a Rage Pro - Works in OS X fine (Shipped with the machine - no problems) Shows up in Mac OS X fine.

    About the 9600 card info - it's in the Apple System profiler on the Mac but I need to jot that down, I'll do that in a bit but now... here is what I found from Low End Mac (lowendmac.com)

    Macintosh 9600 Video Info:

    VRAM: 4 or 8 MB using OEM version of ixMicro TwinTurbo video card
    Video: supports resolutions to 1280 x 1024 at 24 bits and up to 1600x1200 at an unspecified bit depth

    That help?

    :D
     
  4. RGunner macrumors 6502a

    RGunner

    Joined:
    Jul 3, 2002
    Location:
    Midnight Sun
    #4
    yep

    twin turbo wont work in 10.3 (any version)... even as a second display (it just has no drivers).

    buy a radeon or another rage.
     
  5. LimeiBook86 thread starter macrumors 604

    LimeiBook86

    Joined:
    May 4, 2002
    Location:
    Go Vegan
    #5

    This was just a make shift solution before I got the proper VGA/Mac adapter which i just got, everything works now. :D
     

Share This Page