Duplicate Albums Showing on iPhone (iPod Touch, iTunes OK)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by clayj, Sep 20, 2009.

  1. macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #1
    Yesterday, I renamed two of my artists in iTunes ("Touch And Go" is now "Touch and Go" and "Ali Dee And The Deekompressors" is now "Ali Dee and the Deekompressors"), and now my iPhone lists the albums for those artists TWICE. I've tried restoring the iPhone, tried deleting and reripping the songs from scratch, basically everything short of zapping the phone back to factory spec (I don't want to lose my SMS messages and Camera Roll, and there is no option to restore JUST those items).

    My theory is that the database within the iPhone has become borked somehow -- my iPod Touch is not showing the same problem, nor is my Apple TV. If the database is messed up, removing and resyncing music isn't going to fix the problem because the database doesn't actually go away at any point.

    Apple needs to stop treating us like children and give those of us who want it more control over managing all of the internal crap on our devices. If I could just delete the music database within the iPhone, I could try resyncing my music back over and see if that solves the problem.

    Anyone have any ideas? Please don't suggest turning on the Compilation check box for these albums -- that works, but these albums are not compilations and using the check box simply replaces one problem with another.
     
  2. macrumors newbie

    Joined:
    Oct 3, 2009
    #2
    I had the same problem but I was able to fix it. For me the artist that was duplicated on my iPhone 3GS was "Alice in Chains". Some AIC albums were listed in iTunes with the "Album Artist" and/or the "Artist" as "Alice in Chains" while other tracks in other albums were "Alice In Chains". Note that the "i" had conflicting upper and lowercase. This was not easily noticed as iTunes was smart enough to always group all of the AIC tracks together regardless of how "in" was entered.

    Fixing it meant simply editing the Artist and Album Artist fields in all tracks to be the exact same text (i.e. Alice in Chains) and then re-syncing my iPhone.

    Hope this helps.
     
  3. thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #3
    Sadly, that does not help in my case. I *never* fill in the Album Artist field, and my Artist fields are identical for each song in any given album.

    I believe that this problem is occurring because something in the iPhone itself "remembers" these particular songs having their artist names spelled one way (e.g., "Touch And Go") even though the songs have all been changed to have a slightly different artist name (e.g., "Touch and Go"), and now the iPhone is "confused". I *might* be able to fix this problem by doing a factory restore on my iPhone, but I do not want to lose my Camera Roll and SMS text messages.

    Apple needs to get their collective butts on this issue and fix it in the next release. I'll be damned if I am going to start tweaking my songs' info to work around *their* bugs.
     
  4. macrumors newbie

    Joined:
    Nov 8, 2007
    Location:
    The Netherlands
    #4
    clayj,

    I had the same annoying glitch. This is what solved it for me:

    1) Select the entire album in iTunes
    2) Mark it as a compilation in iTunes
    3) Sync iPhone
    4) Unmark it as compilation in iTunes
    5) Sync iPhone again

    Perhaps you don't need to sync it in-between marking and unmarking, I'm not sure, but this worked for me so this is what I did to the various albums that were affected. Hope it helps for you too.
     
  5. thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #5
    SK, I'll try this solution tonight and let you know if it works. (Don't know why I didn't think to try this!)

    Thanks!
     
  6. thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #6
    Nope, no joy. As soon as I turned off the Compilation check box on the songs and resynced the iPhone, the songs that should have been in one album appear in two again. I tried this both ways: Setting the Compilation check box for each song individually, and setting it for multiple items (the entire album) simultaneously. No matter which way I tried, as soon as the Compilation check box was turned off, the album duplication returned.

    Come on, Apple! FIX THIS! :mad:
     
  7. thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
  8. thread starter macrumors 604

    clayj

    Joined:
    Jan 14, 2005
    Location:
    visiting from downstream
    #8
    Problem Solved!

    Here's the answer:

    For these two particular artists, I not only had music on my iPhone -- I also had ringtones, some of which had the same song name. The problem stemmed from the fact that I did not also update the artist names for the ringtones. In my case, it was:

    SONGS
    Touch and Go - Would You...
    Touch and Go - I Find You Very Attractive
    Ali Dee and The Deekompressors - Go Speed Racer Go

    RINGTONES
    Touch And Go - Would You... (note the capital "A" in "And")
    Touch And Go - I Find You Very Attractive (note the capital "A")
    Ali Dee And The Deekompressors - Go Speed Racer Go (note the capital "A")

    As soon as the songs got copied onto the iPhone, the "conflict" between them and the ringtones caused the duplication of albums in the list of albums. Once I adjusted the ringtones so that their artist names matched the artist names of the songs, the problem went away.

    So, lesson learned. But Apple needs to handle this sort of thing better. Ringtones and songs should not "fight" with each other like this.
     
  9. macrumors newbie

    Joined:
    Oct 19, 2009
    #9
    I have the same problem on my ipod touch. im running the 3.1.2 firmware and most of my albums are duplicated. It wasnt this way until recently and i made no changes to the collection. im beginning to think it was the software update that caused it. please advise me.
     
  10. macrumors newbie

    Joined:
    Oct 3, 2009
    #10
    Nice debugging. I wouldn't have thought of the ringtones angle. Considering that iTunes is supposed to be all about music, it certainly doesn't seem to understand it very well. :rolleyes:
     
  11. macrumors newbie

    Joined:
    Oct 25, 2009
    #11
    arghhhhhhhhhh duplicating albums !!!!

    i cant solve this at all. none of my list of tracks has anything in "album artist" yet i still get a seperate Album listed if there is a different artist on the album ie : if itsa compilation.

    So both Itunes and my Iphone 3G show hundreds of albums rather than the 85 i actually should have.

    Any ideas...........................

    Ive tried a few things mentioned but i cant see that changing the album artist will fix the duplicating album thing as they are blank (and therefore the same) now.

    Any help appreciated.

    APPLE SORT IT OUT !!!
     
  12. macrumors newbie

    Joined:
    Nov 24, 2009
    #12
    iPhone Music Albums appearing many times

    I do have the same problem of having the Albums showing more than once which have different artist names. My most probable bet is the Apple iPhone Software update. I never used to expereience this problem before the update.

    Please let me know if you guys find a fix.
     
  13. macrumors newbie

    Joined:
    Dec 3, 2009
    #13
    I'm not sure how much this will help, but what worked for me was to get just the album that was causing me problems up on iTunes, then go to the View menu and turn everything on. Then I could see what - if anything - was different on some of the tracks that was causing the problem.

    For me, it turned out that on the compliation album I had, some of the Album Artists were down as "Various Artists" and some were blank. If I selected them all and Edited Multiple then they all looked blank - it was only when I checked them all that I noticed the difference. Went and changed them so they all had the same Album Artist and voila - all on on album (I also had the Compliation option checked).

    So, it may be some tag that you don't normally see - try changing View so you can see ALL the information and maybe that'll help.
     
  14. macrumors newbie

    Joined:
    Aug 13, 2010
    #14
    Alright I had the following problem but FINALLY fixed it. For example, I had the John Legend album that has 15 songs. Out of the 15 songs, 4 had other artists on the track. The way I labeled my songs in itunes I followed there format exactly. I didn't put "ft. so and so" under the song name. For the songs with other people I labeled them like this: Artist - John Legend, Andre 3000 Song Name - Green Light Album - Evolver. All other fields were blank. I did that for every song on the album thinking it would group them all together. Well, when I went to my iphone, under albums it had 15 albums of Evolver on it. All with the same songs. But, when I checked under songs in my iphone, there were no duplicates. So I went to itunes and it was the same way, no duplicates. So for some reason the added artists somehow messed with the way it read the songs. Because the only albums it happened on was the one's with other artists. Meaning songs featuring someone else besides the main artist. I always wondered what the hell the difference between artist and album artist was as it seems like the same thing. Well therein lies the solution. I kept all the artist fields the same and put John Legend in all the tracks album artist. And BAM it worked, it lumped all of them together making it one whole album.. Finally, god I hate itunes, between this and the way you have to put the covers in for your flow thing I swear I spent 2 days messing around with it. Oh well it's fixed now. Hope this helps someone.
     
  15. macrumors newbie

    Joined:
    Sep 23, 2010
    #15
    solved itttttt !!!!!

    okay i tried everything listed in this thread i even slected the duplicates and right clicked "get info" then typed in the album artist , artist, and album correctly so now theyre unified with same info but wait a minute theyre good on itunes but on iphone theyre still so here is the solution: 1- copy the edited duplicates onto desktop
    2- delete them from itunes (select move to recycle bin not the keep files!!)
    3- sync iphone(so theyre deleted from ur iphone - ipod touch too)
    4-now move the duplicates from desktop to the itunes(make sure everything the album artist album are the same exactly)
    5- sync your iphone - ipod touch et voila ! no more duplicates worked on my iphone and my freinds ipod nano and my cousins ipod touch hope it works for you guys im sure it will
     
  16. macrumors newbie

    Joined:
    Mar 21, 2011
    Location:
    Atlanta
    #16
    There are so many answers to this question and I feel like folks have answered different problems with various solutions.

    Duplicates can be caused by a NUMBER of things, including (but not limited to):

    1. Slightly different artist (or album artist) name.
    2. Slightly different album name.
    3. Compilation issues.

    For the first two, selecting a whole album and making sure you bulk-change the artist or album name normally fixes it.

    Today, the last one was my problem. Removing/syncing/re-adding didn't fix it. Turning on (and/or back off) the compilation flag fixed it.
     
  17. macrumors newbie

    Joined:
    Oct 13, 2011
    #17
    The duplicates could be eliminated by use of automatic mp3 taggers. There's a handful of freeware ones. Magic MP3 Tagger is a helpful utility, and also there's taghycardia, which is specifically designed to get rid of tag errors leading to album duplication.
     
  18. macrumors newbie

    StatementValue

    Joined:
    Feb 25, 2012
    #18
    Just do THIS:

    i can promise you this will work:
    1) On iTunes, open the ceveral times copied albums INFO (CTRL+I) and then make a slight change like; Example Name > Example name2. Do this is the fields: Artist , Album Artist & Album.

    Example:
    Artist: UKF
    Albumartist: UKF
    Album: UKF Dubtep 2011

    (*Changed to*)
    Artist: UKF2
    Albumartist: UKF2
    Album: UKF Dubtep 20112
    (i only added a 2 in those 3 fields...)

    Then Syncronise the iPod/iPhone or whatever you have.

    Now Change it BACK to:
    Artist: UKF
    Albumartist: UKF
    Album: UKF Dubtep 2011

    And Sync. again...

    This worked for me :apple::apple::apple::eek:
     
  19. macrumors newbie

    Joined:
    Dec 21, 2013
    #19
    Just registered to say this worked for me on iPod classic 160GB.

    Thanks Sergeant!
     

Share This Page