Dying G5?

Discussion in 'PowerPC Macs' started by Biscuit411, May 5, 2011.

  1. macrumors regular

    Sep 29, 2010
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_1_3 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7E18 Safari/528.16)

    I have a PowerPC G5 running OS X 10.4.11 that might be on it's last legs. I'm not much of a computer geek, so I don't have a lot of answers right now. Here is my problem:

    Last night it locked up, which it rarely ever did. Upon power-button-push restart everything seemed to power up correctly (power light on, no weird noises), but no signal reached the monitor. The monitor even said 'no input signal'. I tried restarting several times, all to no avail. So I thought I'd give her a rest and try again this morning.

    Well, she powered right up. I opened iPhoto and things seemed good. Just as soon as my hopes were up though, it locked up again. This time a translucent black bar came across the top quarter of the screen. I have not tried to restart it again.

    Any insights? I added a new HD (don't know what type) and more RAM from OWC almost two years ago. Other than that, nothing has changed since it came from Apple.

    Any help would be greatly appreciated. I was planning on getting a new Mini once they refreshed. Apple better hurry it up!
  2. macrumors 6502a


    May 3, 2010
    Try a different monitor. If that doesn't help, my next guess would be the GPU.

    maybe someone else will see this, that knows more than I do.
  3. macrumors 65816


    Nov 17, 2008
    Cudi Zone
    Try swapping ram sticks and trying them individually. Could also be the gpu

Share This Page