Early 2011 MBP CPU whine/noise with OS X LION when scrolling with Integrated GPU

Discussion in 'MacBook Pro' started by iPadThai, Jul 26, 2011.

  1. macrumors 6502a

    Apr 25, 2010
    Wow, this one is a total WTF.

    I'm using my early 2011 MBP i7 2.2 17" with OS X Lion installed. If you are using the INTEGRATED GPU and you land on any web page with content and you pinch to zoom in, when you scroll, the mbp makes a WTF noise/whine. It's very apparent even with the fans at idle 2000rpm. I have a scorpio black 750gb hdd and even with the hdd and fan noise, you can still hear the cpu/capacitors (I don' know what it is noise) coming from the CPU side of the laptop.

    It's when you switch to the discrete GPU, it doesn't make this noise. Also, you may not be able to hear the noise on some web pages zoomed in. An example for me was trying to post this new thread, zooming in all the way or halfway didn't make the noise. But viewing any other page (while zoomed in or not) causes this noise to appear when using the Integrated GPU.

    Can other's confirm this "new feature" of OS X LION or am I having bad nightmares of my old DELL laptop days? :confused::confused::confused:
  2. jon08, Nov 4, 2012
    Last edited: Nov 4, 2012

    macrumors 65816

    Nov 14, 2008
    Recently I bought a 512GB Crucial M4 SSD for my 15" late-2011 MBP. Since I'm in a quiet environment, I quickly noticed odd noise (like scratching/screeching) coming from the lower right side of my MBP (where the drive is installed --- at least it seems to be coming from that side) whenever it my MBP is under some sort of load.

    The whine is pretty apparent for example when I perform a search with the app EasyFind, which can quickly find files/folders on your drive. It's really hard to describe the sound: it's like a high-pitched screech/whine that only appears for the duration of the search. I can also hear it when I run the BlackMagic benchmark for example, but it's less audible.

    I can also hear some faint sound coming from somewhere in my MBP during scrolling on some webpages. That sound is different, though: it resembles a bit the actual scrolling sound of a mouse, except it's barely audible.

    At first I thought I have a faulty SSD, but I tried another 512GB Crucial M4 and even a 128GB OWC Mercury Extreme Pro 6G SSD and on each of them there was some sort of barely audible occasional screeching noise/whine coming from the hard drive bay from the very beginning (when I started installing Mountain Lion)

    So my conclusion is that it may be the motherboard (CPU or whatever) emitting this noise, rather than SSDs?? Let me stress that the sound is not present all the time, but only when the computer is active (i.e. under load etc).

    Any ideas? Do you think I should let them replace my MBP's motherboard?

Share This Page