eMac - no power

Discussion in 'Macintosh Computers' started by Dwarf, Mar 26, 2004.

  1. Dwarf macrumors newbie

    Mar 26, 2004
    Hello group,

    I have been long time listener, first time caller.

    Your help is much needed on the following problem.
    I had to have my 1GHz combo eMac unplugged and stored for two months. Before this it had worked properly. However when I plugged it back in it didn't turn on. There was no sound, no hard disk activity, no monitor, nothing. The battery was empty and replaced, the PMU was reset, but no results. I have also checked the AC connector, the fuse, the 3rd and 4th pin on the down converter (according to the instructions on the Apple source manual), they all appear to be O.K. Somehow I doubt is the button. So what else could be wrong? :confused: I don't have any real electronics knowledge but I am willing to try.

    The computer is out of warranty, any help is really appreciated.
  2. blue&whiteman macrumors 65816


    Nov 30, 2003
    really sorry to hear about your problems. I have no idea what could be wrong with it. I assume the apple care didn't run out too long ago since thats the current model out also. I would call apple and see what they say. if its only a little out of the end of applecare they may pay for it. just say things like you expect more from apple hardware and such. might work.

    the problems I see so many of you having with newer machines makes me think apple is using cheaper parts now or just not putting as much quality control into their stuff. its rather pathetic really when I look at how many are not even able to use newer machines.
  3. Dwarf thread starter macrumors newbie

    Mar 26, 2004
    eMac - no power

    Any ideas what might have caused this? There is nothing more sad than a dead mac!

    Blue&whiteman, thank you, for your reply.
  4. nargot macrumors regular

    Jan 29, 2004
    This may be silly but can you access the Hd via firewire? if you have applecare get it checked ASAP!!!

Share This Page