eMac Video help!!!

Discussion in 'PowerPC Macs' started by customisbetter, Dec 19, 2007.

  1. macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #1
    i just bought an emac for 50 bucks. 1ghz, 80 gig drive, and superdrive with no ram.
    im told it boots with an external monitor but the crt does not operate. i guarantee that it is the usual blown analog board and its easy to replace.
    BUT THE PROBLEM IS THAT I CAN'T FIND ONE!!!
    everything i find is the board and the screen. Who needs a screen? the board is what matters!!! so if anyone knows where to find an emac analog board w/o the screen please tell me!
    this is a second gen with ati graphics btw.
    thanks
    -ed
     
  2. macrumors 68040

    KingYaba

    Joined:
    Aug 7, 2005
    Location:
    Up the irons
  3. macrumors member

    Joined:
    Nov 12, 2004
    Location:
    PA
    #3
  4. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #4
    there is a lot of ribbon cable in the way. can anybody say where the bulging or broken capacitors usually are?
    i don't have ram to test it yet but the screen does get a charge when i turn it on.
    i can probably replace those capacitors if i can find them.
    thanks for the help and keep it coming!!!
    p.s. this emac is too old for the extended service plan from apple.
     
  5. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #5
    booted it with ram and it has a thin line down the center that pulses white over and over again faster and faster... until i get so scared that i pull the plug.

    bad capacitors or analog board?
     
  6. macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #6
    Have you tried it with external monitor?

    I've seen mods where people replace the internal CRT with a LCD.

    Otherwise Apple Store would be able to diagnose the problem an give you an estimate on how much it would cost to repair it.
     
  7. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #7
    i got an adapter for the vga today. but there is no operating system on it right now. so im going to get a panther disk from my friend and attempt to install that with an external monitor. not sure if the drive works because it is aftermarket. i guess ill find out soon enough.

    there are no bloated or leaking capacitors because this is an older model. i bet its just a bad analog board.
     
  8. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #8
  9. macrumors G5

    Consultant

    Joined:
    Jun 27, 2007
    #9
  10. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #10
    it doesn't look like a raster shift problem because its a horizantal effect, (nothing on the sides) and not a vertical raster shift problem (screen moving upwards).

    ill take a look at the flyback transformer and see if it is damaged, likely cracked or covered in huge amounts of dust. if not ill think about the cable.

    thanks guys! anything else is still helpful.
     
  11. macrumors 6502a

    Flyinace2000

    Joined:
    Sep 28, 2004
    #11
    We still have eMacs covered under warranty for another year or so. They still sold eMacs via the educational store much later than the regular store.
     
  12. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #12
    ok i took the thing apart to find the previous owner was not mechanically minded. almost all of the crews were gone or the wrong size. oops.
    so i replaced the hdd with the one from my imac and put it all back together. i plugged in the power cable and i hear a hiss from the crt. i unplug it and the hiss continues for a second and dies. weird. so i the press the power button... nothing. everythink looks good except the weird sound. i pressed the reset button but that did nothing. im freakin out, can anybody help me?
     
  13. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #13
    alright the emac runs!!!!
    i tightened some more screws and slapped it a few times and that did the trick. it still does that crazy flash thing and im worried about it.
    should i just let it be or can it cause damage? see previous video btw.
    thanks for all help!!!
     
  14. macrumors 6502a

    Flyinace2000

    Joined:
    Sep 28, 2004
    #14
    That flashing thing is sooo cool!
     
  15. thread starter macrumors member

    Joined:
    Oct 21, 2007
    Location:
    guess
    #15
    its cool that i can cover it with a towel but it makes a pretty annoying noise.
    i don't care. its totally worth fifty bucks.
     

Share This Page