eMac with USB problems

Discussion in 'Macintosh Computers' started by smharmon, Feb 6, 2004.

  1. smharmon macrumors member

    Jan 26, 2004
    Everytime I start up my eMac (it is brand new, got it a week ago), I have to unplug all usb devices, and plug them back in to get them to work. Any suggestions how to fix it?
  2. sethypoo macrumors 68000

    Oct 8, 2003
    Sacramento, CA, USA
    I would call Apple ASAP on this one.

    My mom purchased an eMac about a year and a half ago. It gave us so many problems we returned it and put the money towards a 17" iMac.

    As a Apple Service Manager told us over the phone, "eMacs historically have a lot of problems. You're not the first, or the last."

    If I were you, I'd get rid of it and invest in a better computer. eMac's are very unstable at this point.
  3. Dub macrumors newbie

    Feb 5, 2004
    Cardiff, UK
    Maybe they improved them since - my eMac works fine.
  4. blue&whiteman macrumors 65816


    Nov 30, 2003
    just look through these forums and you will see that people have problems with ALL mac models. its not just the emac. god, just look at all the problems powerbook owners have been having now and for the last couple months. all manufacturers of all kinds of products make the odd defective product. its just part of life in the consumer world so don't label the emac as a bad system. all current macs are just as bad if not worse for problems.

    to comment on your problem I would try zapping your pram about 5 times. if that doesn't work then call apple.

Share This Page