Email address is already verified for another Apple ID.

Discussion in 'Apple Music, iCloud and Apple Services' started by phinsup, Oct 24, 2011.

  1. macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #1
    I'm totally confused, my apple id is me@me.com, however i am unable to associate my email with my me@me.com. I did a search on the apple id site to see if any apple id's had that email attached to them, an old id did, so i deleted that email from the old id. Now when I do a search it says no id's are associated with that email, however I am unable to add the email to my me@me.com apple id.

    The problem is I can't add that email to anything now, FaceTime, iMessage, etc....

    Any suggestions? What am I missing?
     
  2. macrumors 68040

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    Either it's in use by someone else or you didn't migrate it over if you had a MobileMe account previously. Like you, my AppleID was user@mac.com from the .Mac days. I still used it for other things but the .Mac/MobileMe service. I, like many, was under the impression that even if you did leave in inactive, you would still be able to use that as your e-mail in iCloud, that ended up not being true. After reading various threads and people's problem, that's how I understand it, I could be wrong but at the end, chances are you won't be able to get that e-mail address.

    You could still use your AppleID for iChat, Facetime, etc. but not the old e-mail.

    *EDIT* I just re-read your post. Your AppleID should still work even if your e-mail is no longer yours. I'm still able to use my @mac.com for iChat, Facetime. What's the error message when you try to use it for iChat, iMessage, Facetime?
     
  3. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #3
    I migrated it from mobile me and am still using the email my MobileMe account is good until 2012, so i was active. The email was attached and verified to another apple id prior to moving to iCloud. i deleted it from that apple id, then attempted to add it to the applid that it matches.
     
  4. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #4
    After a 1 hour plus phone conversation this morning with apple I have determined they have no idea what is going on with the apple id's. They basically said you are screwed get a new email addy if you want i to work. Somehow my email address is in use, even though it doesn't show that any where in their system.

    I didn't mind paying for mobile me, everything was working fine. now the email addy i use for FaceTime is gone, i can no longer use it.
     
  5. macrumors member

    Joined:
    Jul 9, 2008
    #5
    How did you attach your me.com to another Apple ID? Your me.com account is its own Apple ID.

    The fact that you can't move your me.com address to another Apple ID has long been something people have wanted, but is impossible to do now.
     
  6. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #6
    Originally my @me.com email was attached to an older USERNAME apple id. It worked fine, was verified, etc... This was long before the apple id was an email, it was just a username and you could use any email you wanted with it. When I moved from me to iCloud it created a new id for me, which is uername@me.com, however it couldn't verify the username@me.com email address because it was still associated with the old USERNAME apple id, which I use for store purchases, etc... Soooo, I deleted the @me.com email from the USERNAME apple id, then attempted to verify it under the username@me.com apple id, however it will not verify with any account now. So my @me.com email address cannot be used any longer with any apple id, even though I have an apple id named with that email address. Essentially my @me.com email is now unusable with apple's apple id system and they basically said sorry, but there's nothing we can do.
     
  7. macrumors 68020

    Joined:
    May 15, 2005
    #7
    mobileme?


    are you using mobileme on snow leopard for any functions?
     
  8. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #8
    nope both of my macs are Lion.
     
  9. macrumors 68020

    d21mike

    Joined:
    Jul 11, 2007
    Location:
    Torrance, CA
    #9
    On the OLD USERNAME Apple ID. You had your userid@me.com as the Primary Email Address, right? When you removed it did you replace it with another email address and verify it? I believe you need to replace the email address with another one to release the first one.
     
  10. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #10
    I did verify a new email on the account on the old id.
     
  11. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #11
    Spent another 31 minutes on the phone with Apple he was very helpful very nice guy but basically told me that the email is attached to the old account somehow and there's really no way they can fix it.
     
  12. macrumors newbie

    Joined:
    Oct 28, 2011
    #12
    phinsup, I'm in a similar (but not exactly the same) boat. I did a live chat with MobileMe support. They reproduced it, kicked up a level and it's now with "Engineering". I'm still waiting to hear back.
     
  13. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #13
    I did that last night as well so we shall see. Let me know how yours goes.
     
  14. macrumors newbie

    Joined:
    Oct 28, 2011
    #14
    They fixed it for me.

    "The Engineering team has reported to [a MobileMe Senior Advisor] that the issue should now be resolved." Good luck.
     
  15. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #15
    Let's hope i get the same result!
     
  16. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #16
    still sitting with senior level technician. they get back to me every once in a while to apologize for it taking so long. very comforting. :(
     
  17. macrumors regular

    Joined:
    Nov 3, 2011
    Location:
    UK
    #17
    I've spent hours on the phone to apple about this. They have been very helpful but they now forwarded it to engineering and its been a few weeks with no response to my emails anymore.....
     
  18. macrumors member

    Joined:
    Nov 13, 2008
    #18
    who did you email in reference to your issue? I been using my username@me.com as my appleid for the longest and now today Im not able log into my account. Seems like my me.com account doesn't exist no more.
     
  19. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #19
    You have to go to support for MobileMe, then go into chat. Then every 3 or 4 days someone will email to let you know how sorry they are.

    About the only progress I have seen so far is my apple id has now been deleted (for about a day).

    No emails about why, maybe that's progress?
     
  20. macrumors 68030

    vitzr

    Joined:
    Jul 28, 2011
    Location:
    California
    #20
    I have a current, (paid in full till the very last day of operation) MobileMe account. I migrated it successfully to iCloud to preserve my sole account for both iTunes & iCloud.

    After a few weeks of trouble free operation, out of the clear blue, I could not log in. Calling Apple was a total unmitigated disaster.

    Not only did they have no clue, they seemed more interested in convincing me to start over with a new email address, than for them to do due diligence to resolve the problem I had no involvement in.

    I'd love nothing better than to be telling you how great Apple is. But lately it is just one problem after the other. I must say, they have no problem shifting the burden to the customer.

    It's a good thing I have more than just Apples Eco system to use. Thankfully I can escape the frustration of Apples ineptitude by picking up my new ThinkPad, SGSII & leaving the dysfunctional iToyz to collect dust.
     
  21. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #21
    They did the same thing to me. Just start a new account and ditch the email you've been using for everything over the past couple of years.
     
  22. macrumors regular

    Joined:
    Nov 3, 2011
    Location:
    UK
    #22
    I'm dealing with senior support agents in apple care

     
  23. macrumors member

    Joined:
    Oct 6, 2010
    #23
    I've spent weeks with a Tier 2 specialist, to no avail. He pointed me back to MobileMe support (which is kind of odd since I migrated from MobileMe to iCloud weeks ago). But I'll try that route.
     
  24. thread starter macrumors 6502

    Joined:
    Sep 19, 2008
    Location:
    SE Florida
    #24
    Don't hold your breathe.
     
  25. macrumors 68030

    vitzr

    Joined:
    Jul 28, 2011
    Location:
    California
    #25
    Very... Very True.

    Prior to writing my post, I'd already escalated my _fourth_ call to a top tier tech support iCloud specialist working with a customer relations manager on my case.

    Since I cannot escalate this to Adobe, I'm stuck with that little fledgling company called Apple.

    Just kidding about Adobe - maybe - ha... ha.
     

Share This Page