Email app does not autoupdate/notify me of new emails.

Discussion in 'iPhone' started by amazingdm, Nov 17, 2010.

  1. macrumors 6502

    Jul 2, 2010
    Why is this?
    (It's not a setting problem)

    My app will not update or notify me of new emails until I actually go into the app.
    Today I woke up and it said last updated 11/16/2010 at 5pm.. a whole day ago...
  2. macrumors regular

    Jan 8, 2008
    sounds like Fetch has been turned off

    but you claim it's not a settings problem so...
  3. thread starter macrumors 6502

    Jul 2, 2010
    No, it's not off..
  4. macrumors newbie

    Jun 9, 2010
    Under the "Fetch New Data" menu, go to Advanced and change to fetch for that particular account.
  5. thread starter macrumors 6502

    Jul 2, 2010
    As opposed to Push?
  6. ajarnfalang, Nov 17, 2010
    Last edited: Nov 17, 2010

    macrumors regular

    Oct 27, 2010
    I hear you.

    iOS does this sometimes. I think most people here wont understand you because they always "Fetch" their mail.

    I have my mail on PUSH and my Fetch set to "Manual". Because I come from Blackberry I want it to be like that. But, iOS unfortunately is not as reliable with Push Mail as Blackberry. This is one of the few things Blackberry does better than anyone.

    It has happened to me twice in 2 weeks. So, I expect once a week for this to be an issue.

    Basically, on my Blackberry I can tell when the internet connection has been lost overnight for some reason because instead of an all capital letters EDGE it reads edge with lower case letters. So, I knew to just toggle the connections off and on again. It would reconnect to my EDGE and then it would start beeping and loading all my mail that I got overnight.

    So, the iPhone exhibits this same behavior, however, the E and the 3G in the iPhone don't change. So, there is no way of knowing if the connection is active or there is a problem.

    I found out this morning because I opened the email app and it said there was no connection (the last time PUSH was not working, the app did not give me this error).

    Anyway, regardless of whether or not you see this error, open the internet and make sure that you have a connection. Turn the Airplane Mode on and back on to reset all connections. You can also try just toggle DATA.

    Then, go to your mail app and toggle PUSH on and off. It'll start working again.

    Doesn't happen often, but it does sometimes. Internet connections are not reliable. Sometimes the connection 3G or EDGE, to the provider will disconnect and connect again. This messes up with the push mail. You can also try to PUSH and set the fetch, but this would defeat the purpose of PUSH. '

    I have my FETCH off because going to fetch mail every so often wastes battery and DATA.

    I should say the way I noticed something was wrong today was because I woke up. Took the phone off the charger. This was at 4.40am. Went to work. at 7.30am it was still at 100%.

    hmmm.. So, I opened the email and that's when it gave me that there was no Data Connection. Well, no wonder it was still at 100%. Once I toggled the data and my push. Push started working again, and the percentage sure started dropping after that :D

Share This Page