Emailing Contents of Safari Page

Discussion in 'Mac Basics and Help' started by andy317, May 12, 2008.

  1. macrumors member

    Joined:
    Mar 13, 2008
    #1
    Hi all,

    I have just emailed myself a link from my Dad's Imac to mine and it worked fine.

    Now I need to email one back to him and when I click on "Mail Link to This Page" or "Mail Contents of This Page" it won't let me do it.

    The screen capture is attached.

    Any help would be greatly appreciated.

    Regards
    Andy
     

    Attached Files:

  2. macrumors 6502

    Joined:
    May 4, 2008
    Location:
    PA
    #2
    Are you able to open your email program and compose a new message and send it? What app are you using to sending to receive?
     
  3. macrumors 65816

    merl1n

    Joined:
    Mar 30, 2008
    Location:
    New Jersey, USA
    #3
    What email client are you using as a default? Safari will only support the Apple Mail program to do an operation like this.

    You can set Apple's Mail program to be your default by:

    Choose Mail > Preferences, and then click General. Use the Default Email Reader pop-up menu to choose an email application.
     
  4. thread starter macrumors member

    Joined:
    Mar 13, 2008
    #4
    Thank you for your replies, I have now sorted this.

    For some reason when I checked my default email reader it stated Mail 3.2, I decided to go in and click on Mail again and this has rectified the problem.

    Cannot explain why it would not recognise it in the first place.

    Regards
    Andy
     
  5. macrumors newbie

    Joined:
    Feb 6, 2009
    #5
    gmail is the problem

    Hi everyone,

    I had this problem for a long time, removed firefox a couple of times no change, today I removed the gmail notifier as well and voile it works. In the preferences mail was always set as default but if I clicked my gmail box it would go to firefox and when I tried to mail contents of the page safari would generate a message that mail was not installed when in fact it was and was also set as default. I do not know why gmail would start firefox, anyway it works now.
     

Share This Page