English UK spelling on Office Word

Discussion in 'Mac Apps and Mac App Store' started by Amy2005, Apr 18, 2008.

  1. macrumors regular

    Aug 10, 2005
    North Yorkshire, England
    I am trying to change my Office Word dictionary to the UK English one. But whenever I seem to change it it still seems to think that I'm spelling words like 'colour' wrong and 'recognised'. Does anyone know how I can change the dictionary please?
  2. macrumors 6502a

    Nov 21, 2007
    London, UK
    Which version of Office are you using?

    In Office Word 2004, I choose the menu Tools -> Language... -> [Select English (UK)], and click Default.

    Do check that you have installed the extra languages when installing Microsoft Office.
  3. macrumors newbie

    Jul 1, 2009
    English UK spelling on Office Word

    Thank you for the post, I had been trying to get UK English to default for ages.
    Very Helpful, thank you! :)
  4. macrumors regular

    Aug 23, 2007
    You can also set it so the system is British English as well (which I think some applications obey like Pages)...

    System Preferences > International > Edit List... > Tick British English :)
  5. macrumors G3


    Mar 20, 2007
    Find it bizarre Apple hasn't made OS X automatically change to "British" English based on location, or at least ask the user when OS X is installed.

    Also, really annoys me how it has become "British" english and American English is just "english".
  6. macrumors newbie

    Jun 25, 2009
    in a house
    well, that's because they are different after 230 years.
  7. macrumors regular

    Mar 1, 2007

    But it should be North American English, and "British English" should just be English. Because thats where it originates, England. Not British as us Scots, Welsh and the Irish all spoke a form of Gaelic.
  8. macrumors 6502a


    Dec 27, 2008
    awesome!! now i can choose to spell as an american!! yaaay :p
  9. MattZani, Mar 23, 2011
    Last edited: Mar 23, 2011

    macrumors 68020


    Apr 20, 2008
    this still changes anything with 'ising' into 'izing' which is WRONG.

    And before anyone says resurrection, this is the thread that comes up when you search about Uk dictionary word for mac.
  10. macrumors G3


    Mar 20, 2007
    Did you change the language as well as the dictionary?

    Tools -> Language.

    I still don't understand why OS X doesn't ask you when you first make an account what language you want, rather than assuming every user is an American, even if they select the UK as their location.

    Also, Word should obey OS X's language selection by default, and if users want a different language in Word, they can do it by the method above.

    I hate seeing "izing" on articles..
  11. macrumors 6502

    Nov 19, 2003
    Strictly speaking, 'izing' is correct in words that derive from Greek roots; however, when a generation of journalists and printers arrived in the 1970s or so who hadn't done Greek and Latin in school, British newspapers decided to standardi(z)se all 'ize' spellings to use 's' instead of 'z'.

    I'm having this spellchecking problem randomly on Word for Mac 2011; on some documents, I can set the language, the spelling and even the custom dictionary to UK English, and it'll still screech at words like 'colour' or 'cheque' or 'furore'. I'd love to find a solution to this.
  12. macrumors 6502

    May 25, 2011
    Commonwealth English would be a better name...it refers to British commonwealth (former British Empire) countries, not Britain (or England.)
  13. macrumors 6502

    Nov 19, 2003
    Leaves out a few countries that speak English (and have been an important influence on the language), though, like Ireland.
  14. macrumors 65816


    Feb 25, 2003
    Cold beer land
    Can't call it North American English. Canada is similar to UK with "colour", but more like US with "tire".

    One way Ireland has affected English speech is .... Guinness :)
  15. macrumors 65816

    Nov 26, 2007
    Austin, TX
    Not sure if it's the same for 2011, but from the help docs of 2008:

  16. macrumors newbie

    Nov 2, 2011
    Hi everyone,
    apologies to revive an old thread but I've been using Word for 8+ years and have never figured out how to fully change the language settings to UK English, it's driven me nuts. I've always had the same problem of it changing back, but I have finally managed to settle this, so for anyone else who's interested here's how...

    This is for Word 2011.

    1.Copy and paste some text into a new word document.
    2.Select the text and then go: Tools>Language.
    3. Select 'English (UK)' and hit the DEFAULT button.

    Every document you write up after this will now be checked against UK English, so no more red lines under colour, honour, etc!

    Hope this helps.
  17. macrumors 6502

    Jul 19, 2006
    Thank you, Thank you, Thank you. I took a copywriting job with and Aus based company and kept getting criticized for using US spelling. I told them I had changed it in preferences but was still seeing the wrong prompts. Now I know why.
  18. macrumors newbie

    Sep 30, 2012
    Cornwall, UK
    Been trying for months to get this to work. Now, thanks to you, all working as should be for British English.

    There was note concerning other English speaking countries. Aussie has its own version of English, closely related to US English, while Kiwi is more akin to UK English.
  19. macrumors newbie

    Apr 9, 2013
    Troops89, thanks heaps.

    I tried changing the dictionary and the language and it was driving me nuts. I'm an English teacher in Australia, so this was seriously irritating me. Finally the default language has actually changed.

    As to the person who said that Australian English is more akin to US English, do you mean there's evidence of this in the Word dictionary? What are you basing this on? Australian English is definitely not like American English. We only use dictionaries with UK English or Australian English. ... Though, of course, Kindle English and iBooks English are probably creeping into usage!

  20. macrumors newbie

    Feb 15, 2014

    Try going to: Apple - System Preferences - Language and Text - Text, and under Spelling select "Australian English"

    That solves it for me so hopefully it will for you.

    Also the "language" feature in work works the same as "bold", you need to select the text first and it will then apply that language filter over the top of it.

  21. macrumors 6502a

    Feb 17, 2012
    Uh! Seriously !! Makes me think what is the Irish contribution to the English Language just besides they speak their own way The Irish Way with an Irish Accent !

Share This Page