1. Welcome to the new MacRumors forums. See our announcement and read our FAQ

Erase Free Space

Discussion in 'Mac Basics and Help' started by Jmanp17, Nov 27, 2012.

  1. macrumors member

    #1
    So I was doing the Erase Free Space function on my iMac OS X 10.4.11, and I started with 77GB, and a-mid erase, I ended up with 33GB. I've lost a ton of space and I need it back! What caused this? How do I regain GB? HELP!
     
  2. macrumors 65816

    frankblundt

  3. macrumors member

    #3
  4. macrumors 65816

    frankblundt

  5. macrumors member

    #5
    Okay, can't find a var folder anywhere so I just found my Library folder, then the Caches and now found the temporary files folder, which Is empty. Should I just delete this folder?
     
  6. macrumors 65816

    frankblundt

    #6
    the var folder is hidden from normal view, but you can get to it in
    Finder > Go > Go to Folder..
    type in
    /var/root/Library/Caches/TemporaryItems
    it would be better to use the Terminal app if you can but not if you haven't used it before.

    It you read through the comments in the link I posted you'll see some people found the files in other places also
     
  7. macrumors member

    #7
    Gah! It says Folder is not found! So I just typed var and I tried to manually navigate, but root has a (-) Can't get in sign on it. And I don't think I have terminal, I tried to open it, and it just bounces and disappears. Any way around this?
     
  8. macrumors 65816

    frankblundt

    #8
    At this point, not without Terminal I suspect. Bounce and die seems odd/wrong.
    Its the one in Applications > Utilities right?

    .. but dinner time now sorry :) Will check back later if no one else has jumped in.
     
  9. macrumors member

    #9
    Yep, It's showing as a white page and just bounces and dies. Can I reinstall Terminal? I really need that space back! I'll check back in the morning.
     
  10. macrumors 604

    Jessica Lares

    #10
    He doesn't have admin rights to the machine. I guess that's why Terminal is giving him issues? My root is also marked as - too on my MBP though...
     
  11. macrumors member

    #11
    Is there any terminal software I can download?
     
  12. macrumors regular

    #12
    Let's try to figure out why the Terminal you have doesn't open first.

    Have you tried to close all open Applications and then
    Log Out (Shift + Cmd + Q) and Login.
    or
    a complete Shut Down and restart of your computer?

    Since you'll eventually want to use sudo anyway to remove the sparseimage(s) you may as well log into an Admin account if you normally run your Mac as a Standard User. If there are different users on your computer trying to start Terminal in a different user account may also work. If it does that could indicate that there is something wrong with something like the Terminal Preference file in the Library of the Home Folder of your daily account.
    Since you're using 10.4.11 that Library folder should be visible and you can move the com.apple.Terminal.plist file from the Preferences folder inside to the trash. Then restart you computer. A new .plist will be recreated when you restart your computer and try to open Terminal again.
    ~/Library/Preferences/com.apple.Terminal.plist

    Does Terminal open after trying any of these suggestions?
     
  13. Jmanp17, Nov 28, 2012
    Last edited: Nov 28, 2012

    macrumors member

    #13
    This might be the problem - After trying all, I went into Preferences and searched three times, but I didn't see the com.apple.Terminal.plist file. It's not on my computer! Already tried the Repair Disk Permissions/Verify Disk. Still nothing!

    OH AND - I just found an EFTFile1.sparseimage in my TRASH!!! It looks like a .dmg file! Jackpot! Should I just secure empty trash it?!
     
  14. macrumors regular

    #14
    Hope you don't mind me asking but are you sure you checked the correct Library? Can you make sure the Terminal.plist file is not in the Library of your Home folder by using the Go menu and pasting ~/Library/Preferences/ in the Go To Folder box?

    Can you check the file in the Trash with cmd+i to make sure that it isn't locked and see if you actually have permission to delete it from Trash? Especially with a non-functional Terminal it would be a pain to get something like that stuck in there, imo.
     
  15. macrumors member

    #15
    Yes! I checked there along with other Preference files. And I'm positive this is the file I want. It has the exact amount of GB I lost and there was no lock symbol on it!
     
  16. bluespaceoddity, Nov 28, 2012
    Last edited: Nov 28, 2012

    macrumors regular

    #16
    Give at go and see what happens. Maybe use Option Click to empty the Trash.
    Call me paranoid but I suggest making sure the process doesn't get interrupted.

    Late edit.
    I just went a bit further back than this thread and I think I understand Jessica Lares' comment above about the Admin rights a little better now. Guess I should have looked back a little sooner. Is this still the same Mac about which you asked Erasing questions in October? If so it is quite possible that your school prevents the use of Terminal or you ended up trashing more files than you intended. Either way I can stop suggesting solutions for that issue.
     
  17. macrumors 65816

    frankblundt

    #17
    In the comments in the recovery post I linked to, one person did find the file in the trash but was quite emphatic about NOT using the secure option to empty the trash. Just empty it normally. If you still want to erase the free space (why? if you don't mind me asking) then do what you did before, just don't interrupt it
     
  18. macrumors member

    #18
    Right on, I'll just right click it in the trash and press "Empty trash". And I have a bunch of Apps and files that I deleted and wanted to erase securely, after using "Secure Empty Trash."
     

Share This Page