Error -192

Discussion in 'Mac Apps and Mac App Store' started by Nermal, Mar 1, 2004.

  1. Nermal Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #1
    I've just installed a music-writing app (Finale NotePad 2001) on my brother's old Mac. But when I try to run it, I get the message:

    What does this error mean? Not enough memory? Hard drive's full? I need to stand up and rotate 3 times before it will work? And why can't these errors be descriptive?

    Update: I just rebooted and rebuilt the desktop (because the app had a generic icon). The icon is the correct one now but it still gives me an error -192. But what's really intriguing is that the system-wide menu bar now looks like OS 8 (I'm running 7.6.1). I noticed that the Finale installer copied over a file called "Appearance" which must have something to do with it. So I tried opening the Appearance control panel, and got another error -192. What's going on here?

    Update 2: I did a Get Info on the Appearance control panel, and it says that it's from Mac OS 8.5! I also found that the Appearance Extension has been updated, it's from Appearance SDK 1.0.3.
     
  2. RBMaraman macrumors 65816

    RBMaraman

    Joined:
    Jul 25, 2002
    Location:
    Prospect, KY
    #3
    Nermal,

    Since ubergeek was kind enough to post the link (but too lazy to click one time to look up the answer :D), I looked it up for you.

    Error -192:
    resNotFound
    Resource not found

    Your welcome.
     
  3. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #4
    Naturally, "resource not found" isn't much more help than "error -192" :(

    If I had to guess, I'd say that maybe Finale needs OS 8.5, since it installed an 8.5 control panel. I couldn't find system requirements anywhere so I just downloaded the oldest version and tried it.
     
  4. RBMaraman macrumors 65816

    RBMaraman

    Joined:
    Jul 25, 2002
    Location:
    Prospect, KY
    #5
    I'd say you're right. If it installed something from OS 8.5, I would say that OS is the minimum that the program would run on.

    Sorry I couldn't be of more help.
     
  5. janey macrumors 603

    janey

    Joined:
    Dec 20, 2002
    Location:
    sunny los angeles
    #6
    hehe. i knew the website existed but yeah i guess i was too lazy to click two times and scroll a little :)
     
  6. HexMonkey Administrator

    HexMonkey

    Staff Member

    Joined:
    Feb 5, 2004
    Location:
    New Zealand
    #7
    Is this a 68K mac? I recall I used to get an error that I think was -192 on my old Quadra when I tried to run PPC only applications. If you have ResEdit on that computer, open the applicaton in it and see if there is a CODE resource. If there is, check the sizes of each of these resources. If there are no CODE resources, or the sizes total less than a couple of KB, it will be a PPC only application.
     
  7. Nermal thread starter Moderator

    Nermal

    Staff Member

    Joined:
    Dec 7, 2002
    Location:
    New Zealand
    #8
    I'm not even going to bother turning the machine on the check, I'll just guess:

    - app installed a control panel from 8.5
    - i'm assuming that the app therefore needs 8.5
    - 8.5 needs a PPC
    - therefore the app needs a PPC
    - i'm trying to run it on a 68030 :(

    I couldn't find any system requirements for that version the app, but I've found a low-end PPC that meets all the requirements for the latest version. It's being auctioned on TM and it's been sitting at $22 for the last couple of days. I might end up getting it :)
     

Share This Page