Error connecting to wireless network

Discussion in 'Mac Basics and Help' started by tcchang7, Sep 21, 2006.

  1. tcchang7 macrumors newbie

    Joined:
    Sep 21, 2006
    #1
    OK, I know there are a million threads devoted to this, but I couldn't find one that I could understand, or matched my situation....

    So I just got YahooBB internet in my apartment... In Japan. Whenever I try to connect the wireless, it always says there is an "error connecting to wireless network." I have secured the network with a WEP password (as best I could with the Japanese), and even though I put in the password, it doesn't work. I can connect fine with the ethernet cable, but it'd be great to have the wireless.

    (Especially since my primitive apartment doesn't have enough outlets to charge my laptop in the same room as the ethernet cable. :mad: )

    So, any help, please?
     
  2. SilentPanda Moderator emeritus

    SilentPanda

    Joined:
    Oct 8, 2002
    Location:
    The Bamboo Forest
    #2
    I would suggest removing all protection first and seeing if you can connect that way. Then add 1 type of protection and get that working then move onto the next kind.

    Is your password in Japanese or is the wireless router in Japanese? There might be some sort of disconnect between the character set on the computer and that on the router.
     
  3. tcchang7 thread starter macrumors newbie

    Joined:
    Sep 21, 2006
    #3
    I'm not sure if the wireless router is in Japanese; In fact I don't even know how that works. But I'm on an English keyboard, so the password is in English characters... The screens I had to go through to secure the network were in Japanese though, which I obviously couldn't read.

    The weird thing is, when I first got the internet, it would say the same thing, but if I turned off the airport and turned it on again, it would magically connect to the wireless! Then one day, it stopped connecting all together.

    I read on this forum somewhere that uploading/downloading software will mess up wireless connections... is this true?
     
  4. gauchogolfer macrumors 603

    gauchogolfer

    Joined:
    Jan 28, 2005
    Location:
    American Riviera
    #4
    Can you connect wirelessly if you disable the WEP password?

    Can you choose WPA rather than WEP? Sometimes you need to add a $ in front of your WEP password, you might try this as well.

    Ensure that your MAC address is added to the router, if you are filtering these addresses.
     
  5. tcchang7 thread starter macrumors newbie

    Joined:
    Sep 21, 2006
    #5
    OK, i disabled the password, and now the wireless works. But now what do I do about security?

    I don't have the option for WPA, I don't think.

    And how do I add my MAC address to the router?
     
  6. Kelmon macrumors 6502a

    Kelmon

    Joined:
    Mar 28, 2005
    Location:
    United Kingdom
    #6
    I hit this problem recently as well and found that the problem was due to the WEP password and the form that the router expected and what was being sent by the Mac. Basically, you can send passwords in a number of formats (ASCII and HEX spring to mind) and I discovered that I was sending the password (as written on the router itself) as ASCII when it was expecting HEX even through I had typed in a hexadecimal number (something like "12a48fg9"). If memory serves, the dialog that appears when you ask to join the network should allow you to choose the type of password (WEP, WPA, etc.) and also the format (ASCII, HEX, etc.). My advice would be try connecting using different formats and/or types until it works, particularly if you are not sure what it is that the router is expecting.
     
  7. Kelmon macrumors 6502a

    Kelmon

    Joined:
    Mar 28, 2005
    Location:
    United Kingdom
    #7
    The steps necessary to add a MAC address to the router varies between models of router but typically there should be a page in its administration settings that allows this (never tried it myself). In case you don't know where to find it, the MAC address of your Airport card can be found as follows:

    1. Open System Preferences > Networks
    2. From the list of network adaptors displayed, select "Airport" and click Configure
    3. The MAC address is shown as the "Aiport ID" on the Airport tab, such as 00:19:65:2c:0b:12
     

Share This Page