Error creating Open Directory Replica in Mountain Lion

Discussion in 'Mac OS X Server, Xserve, and Networking' started by carlosribas, Jul 22, 2013.

  1. macrumors newbie

    Joined:
    Jun 19, 2013
    #1
    I am encountering problems setting up an Open Directory Replica using the Server.app version 2.2.1 (169) in Mountain Lion (10.8.4) in the OD Mater and OD Replica. I receive the error attached when it attempts to create the replica.

    The message says it is a network error, but the command "changeip -checkhostname" shows that everything is ok with ODM and with the server I want to use as ODR.

    Any help would be greatly appreciated. Thanks.
     

    Attached Files:

  2. macrumors newbie

    Joined:
    Aug 26, 2013
    Location:
    Belgium
    #2
    I've got the exact same problem.

    I setup 2 clean installed 10.8.4 servers.

    I configured one as an OD Master with no problems.
    I then tried to configure the second as a replica and it always fails.

    Both servers have a FQDN.
    sudo changeip -checkhostname shows no error on both servers.

    I tried these instructions: http://www.mountainlionserver.com/s...irectory-replica-in-os-x-mountain-lion-server

    But running sudo slapconfig -preflightreplica 172.16.2.23 diradmin on the replica-wanna-be server gives an error.

    Has anyone succeeded in setting up a replica under 10.8.4?
     
  3. macrumors 68040

    Joined:
    Jul 11, 2009
    #3
    Helpful tip: when asking questions about errors, state the error.

    And yes, I have a 10.8.4 OD Master/replica working fine.
     
  4. macrumors newbie

    Joined:
    Aug 26, 2013
    Location:
    Belgium
    #4
    Good to hear that someone has succeeded in setting up a 10.8.4 replica.

    When I run the slapconfig -preflightreplica command I get the following message.

    2013-08-26 15:03:30 +0000 NSMutableDictionary *_getRootDSE(const char *): rootDSE not found
    2013-08-26 15:03:30 +0000 Error: Unable to determine the master's software version
     
  5. macrumors 68040

    Joined:
    Jul 11, 2009
    #5
    Is 172.16.2.23 your OD Master's IP address?
    What is your DNS setup? Are both master and replica on the same network? Is there a firewall in the way?
     
  6. macrumors newbie

    Joined:
    Aug 26, 2013
    Location:
    Belgium
    #6

Share This Page