error message 9, recboot doesnt work...help!?

Discussion in 'iPhone' started by maximus.darby, Jul 18, 2010.

  1. macrumors newbie

    Joined:
    Jun 14, 2010
    #1
    what do i do? will apple release a fix?
     
  2. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #2
    Have you tried a DFU mode restore?
     
  3. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #3
    yeah still nothing :(
     
  4. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #4
    Before you said you had an error message..now nothing?

    You need to give us a lot more information
     
  5. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #5
    sorry, tried it in dfu mode, still error message 9. loading bar on iphone doesnt move from empty when attempting restore, then error 9 appears
     
  6. macrumors regular

    Joined:
    Aug 17, 2008
    #6
    Take it into Apple. I got that same exact error and the Genius explained to me that it had something to do with the USB. So he replaced it and it worked great. Good luck.
     
  7. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #7
    Fixing common restore issues:

    http://itsalltech.com/2010/07/08/fixing-common-itunes-restore-issues/


    Error 9: This error occurs when the device unexpectedly drops off of the USB bus and communication stops. This can occur if the device is manually disconnected during the restore process. This issue can be resolved by performing USB isolation troubleshooting, using a different USB dock connector cable, trying another USB port, restoring on another computer, or by eliminating conflicts from third-party security software.
     
  8. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #8
    nope, not worked
     
  9. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #9
    What doesn't work? Info?
     
  10. macrumors regular

    SCOTTGAZ9

    Joined:
    Jul 27, 2009
    Location:
    Glasgow,Scotland
    #10
    Same issue for 4 days mate...my other 2 handsets restored and sync fine just the new iphone 4 was giving me problems...tried everything on the forums and Apple site, cleared library,mobile sync and re-installed itunes. took it to Apple today and it did the same instore so instant replacement.

    See thread on 02 forum.

    http://forum.o2.co.uk/viewtopic.php?t=48162
     
  11. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #11
    the update, plugged it into a mac and a windows based pc, you plug it in, it says its in restore mode, you click restore, the iphone flashes on and off, then it gets to a screen with an apple logo and a loading bar beneath it, it doesnt move then the screen turns off and i get error message 9
     
  12. celticpride678

    Joined:
    Feb 15, 2009
    Location:
    Boston, MA
    #12
    Did you try all the solutions in the link I gave you?
     
  13. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #13
    yep tried them all, still not working
     
  14. macrumors member

    Joined:
    Sep 1, 2007
    Location:
    Glendale, CA
    #14
    Agreed..take it back

    Had the same issue twice. First time when I did a general restore when I had iOS 4.0 and the second time when I was upgrading to 4.0.1.

    First time...I fixed myself by doing a complete reinstall of iTunes (that was after going through 2 computers to try to reactivate it). The reinstall worked. After two weeks when 4.0.1 came out, upon downloading the upgrade, it went back to the endless recovery mode with the same error 9 message.

    Best thing at this point: make a genius appt at Apple and let them recreate the issue. I did and they replaced my phone on the spot. They said the exact same thing: maybe an issue on the USB connector port inside the iphone itself. Seemed more like a software issue than hardware, but I wasn't going to complain..since they exchanged my phone for a brand new one! :)
     
  15. macrumors member

    Joined:
    Jul 9, 2010
    #15
    I had the same problem as you with my wife's ip4. My own ip4 updated with no problems. Anyway, used 3 different iphone usb cables, restored, restored in dfu mode, restarted my imac. I attempted this 7-10 times. Still error 9.

    Went to the apple store yesterday and the genius attempted to update to ios 4.0.1.

    Didn't work so Apple gave me wife a new ip4. Updated effortlessly at home.
     
  16. thread starter macrumors newbie

    Joined:
    Jun 14, 2010
    #16
    do i 100% need an appointment or can i just walk in?
     
  17. macrumors member

    Joined:
    Sep 1, 2007
    Location:
    Glendale, CA
    #17
    You can try your luck going to the store without an appt, BUT if they have a busy queue then you'll have to wait it out until they get ahead so they can fit you in.

    Even when I had a 10:20am appt, I waited another 20 min. (The appts are 10-15 min windows) and some customers' issues take longer than others. Just be friendly cause they're human too. My experience: they'll take care of you if you're nice about it!

    Good luck!:)
     

Share This Page