Error: No associated application could be found?

Discussion in 'OS X Mountain Lion (10.8)' started by jmy2469, Jul 26, 2012.

  1. jmy2469
    Expand Collapse
    macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Palm Harbor, FL
    #1
    Upgraded to Mountain Lion yesterday. When getting an e-mail that has a link in it to click on, I get the following message, Error, no associated application could be found. Any idea what is happening with this, and how can I fix it? Thanks for the help. John
     
  2. Weaselboy
    Expand Collapse
    macrumors Core

    Weaselboy

    Joined:
    Jan 23, 2005
    #2
    What is the extension on the file? It sounds like you don't have whatever app is required to view the file.

    For example, if someone sends you a file called reports.xls (an Excel spreadsheet file) you would need Excel or Apple Numbers or some such app to view the spreadsheet.
     
  3. jmy2469
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Palm Harbor, FL
    #3
  4. Weaselboy
    Expand Collapse
    macrumors Core

    Weaselboy

    Joined:
    Jan 23, 2005
    #4
    I think I misunderstood. You mean it is an HTML link to web page? Open Safari and in preferences / general tab see if Safari is set as the default browser.
     
  5. jmy2469
    Expand Collapse
    thread starter macrumors member

    Joined:
    Jun 10, 2010
    Location:
    Palm Harbor, FL
    #5
    That fixed it! I set Safari as default and now everything is good. Thanks for the help!
     
  6. devonsnorkie
    Expand Collapse
    macrumors newbie

    Joined:
    Mar 27, 2013
    #6
    I did this too and it worked thank you for helping. My default always had been Safari, I don't know what happened.
     
  7. dinazabi
    Expand Collapse
    macrumors newbie

    Joined:
    Jan 6, 2012
    #7
    No associted app. could be found

    Thanks all good now. Its working fine.:)
     
  8. 1GatorGirl
    Expand Collapse
    macrumors newbie

    Joined:
    Sep 12, 2013
    #8
    Adding my thanks. I had the same issue, but you helped resolve it.
     

Share This Page