error: two Photo Streams

Discussion in 'iPhone' started by paulold, Oct 16, 2011.

  1. macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #1
    Anyone else have two Photo Stream photo albums in the Photos app on their iPhone? After spending the day trying to get everything set up correctly on my iPhone 4S and all my iOS devices, and two hours with Apple tech support, the only issue I have left is I have two photo streams on my iPhone. One is empty and the other has my streamed pics and seems to be working fine. Tech support suggested I could do a full restore to get rid of the extra album, but I don't feel like going thru all that. I think I'll wait until the next iOS update, unless someone has another solution...
     
  2. macrumors member

    Joined:
    Jun 29, 2010
    #2
    same thing happened to me... i just turned off photo stream, and turned it back on (in the iPhone settings), and it fixed it. Only one photo stream album...

    it might have been bc i had two .me accounts on my phone? I'm not sure. Either way I think I fixed it.
     
  3. thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #3
    Apple had me try the following:

    - turning off/on Photo Stream
    - turning off/on iCloud
    - resetting network settings
    - reset all settings

    Plus we tried turning on and off the phone. The only thing we didn't try was the full restore.
     
  4. macrumors newbie

    Joined:
    Oct 16, 2011
    #4
    Did you use a different email to set up the phone?

    When I set up my iPhone in iOS5 on my 4s, I initially used a Gmail address (which happens to be my apple ID and is connected with the Apple Store). After iOS5 was up and running I switched iCloud from the Gmail address to my "me.com" address and experienced what you are describing; two Photo Streams in the photo app.

    My solution was to delete the existing iCloud account on my iPhone. Then I set up iCloud with the Gmail address (or whatever address you used to set up the phone) and turned on Photo Stream. I took a picture with the camera and waited for it to populate in the Photo Stream, so it would no longer be empty. I then deleted the Gmail iCloud account. This deleted the Photo Stream from the photo app.

    Finally, I set up iCloud again with my "me.com" address and now I only have one Photo Stream.
     
  5. thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #5
    I was a bit confused with my setup because I had the two email addresses - my main AOL address which is my iTunes account and my .me/.mac address from my MobileMe account. And I think whatever combination of confusion I entered into my iPad and iPhone on Friday caused the extra photo stream album to appear in my iPhone and it somehow got disconnected from whatever iCloud account it belonged to. So while I am now only using one Apple ID for everything (my AOL address account) and it's working fine on most of my devices, that empty photo stream is still lingering on my iPhone.

    I did experience one unusual thing while I was setting things up. At first I thought I was going to be someone who had to use both my AOL and my .me IDs - my AOL for buying songs & iTunes Match, my .me account for contacts, mail, etc on iCloud, especially since I had a MobileMe account that I wanted to move (and did move) to iCloud. I read up on it before I set up my iPhone and I thought I was doing things right. But at one point, I noticed that my old .mac account was back. And I think I purchased an app with it on my iPad. What was unusual about it was it had all my really old information (old home address) and it asked me to update my credit card information. I know .mac is supposed to be the same as .me, but it seemed like it was separate. So I think that's part of why my photo stream is messed up.
     
  6. macrumors newbie

    Joined:
    Jul 6, 2010
    #6
    Thanks, this worked for me.
     
  7. thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #7
    Just an update. Finally decided to restore my iPhone, per Apple Care's instructions, and it didn't help. I still have two photo streams in my Photos app. And when I turn off iCloud or Photo Stream, it only gets rid of one. The empty one seems to be a permanent feature of my Photos app.

    I've also learned that my friend has trouble sending me a FaceTime call. My iPhone doesn't receive the call and sometimes my laptop gets the call instead.

    Something is clearly messed up with my Apple ID. And I think this is on Apple's end.
     
  8. macrumors newbie

    Joined:
    Mar 7, 2012
    #8
    I agree, this worked for me too.
     
  9. macrumors 601

    PNutts

    Joined:
    Jul 24, 2008
    Location:
    Pacific Northwest, US
    #9
    You may get some play over in the iCloud forum or possibly even the iOS 5 forum. I don't remember seeing this discussed before over in those two but it's worth a shot if you don't get resolution here.
     
  10. thread starter macrumors 6502

    Joined:
    Mar 3, 2008
    Location:
    Washington, DC
    #10
    problem solved

    All thanks go to tedrusky. For me, my main account is an AOL address and since I had MobileMe, I had a .me account too that I rarely used. And when I originally set up my iPhone, I wasn't sure which address I was supposed to use. It didn't help that the setup screens were suggesting I use my .mac address which totally confused me since I thought those went away some time ago.

    So taking a chance that the extra, empty photo stream belonged to my .me account, I deleted my current aol iCloud account, switched iCloud to my .me address, added a picture to the photo stream on the phone, deleted the .me iCloud account and reinstated my main aol iCloud account. Not only did it work, but my one and only photo stream filled itself back up with the photos that were in there before.

    And now with iOS 5.1, I can delete the photos I really don't want in there. : )

    Not sure why I didn't try this sooner - I don't think I saw the steps as something different from what I was already trying. Thank you! So nice to get rid of that finally!
     

Share This Page