eSellerate fun and games

Discussion in 'Mac Programming' started by caveman_uk, Jun 13, 2005.

  1. caveman_uk Guest

    caveman_uk

    Joined:
    Feb 17, 2003
    Location:
    Hitchin, Herts, UK
    #1
    Last night I started integrating eSellerate into an app I'm writing in Cocoa using Tiger and the new universal SDK. I put all the required parts (the .h the .a and the .rsrc) in the right places and the app compiled for the development settings. It failed to compile on the release settings with an error from the linker saying that the libesellerateobjc.a was out of date (huh?). Has anyone else seen this when compiling on Tiger?

    I was able to get it to compile by running 'ranlib' on the library in question but is there something else I should do? I guess it's something to do with moving to gcc 4.0 in Tiger?
     
  2. mj_1903 macrumors 6502a

    mj_1903

    Joined:
    Feb 3, 2003
    Location:
    Sydney, Australia
    #2
    You are correct, it is a change in how GCC 4.0 handles linking.
     

Share This Page